aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2019-11-07 14:31:29 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-12-23 00:22:07 +0100
commit432ec292ccc8b634facacbd018d08947d204225a (patch)
treecc8d4ce6d7e16fd2fefb4e4223776b77b1953f5f /package
parent383abffb1179a142b4c8f86559baad5b24d391c3 (diff)
downloadupstream-432ec292ccc8b634facacbd018d08947d204225a.tar.gz
upstream-432ec292ccc8b634facacbd018d08947d204225a.tar.bz2
upstream-432ec292ccc8b634facacbd018d08947d204225a.zip
rpcd: add respawn param
The rpcd service is an important service, but if the service stops working for any reason, no one will ever respawn that service. With this commit, the procd service will monitor if the rpcd service is running. If the rpcd service has crashed, then procd respawns the rpcd service. Signed-off-by: Florian Eckert <fe@dev.tdt.de>
Diffstat (limited to 'package')
-rw-r--r--package/system/rpcd/Makefile2
-rwxr-xr-xpackage/system/rpcd/files/rpcd.init1
2 files changed, 2 insertions, 1 deletions
diff --git a/package/system/rpcd/Makefile b/package/system/rpcd/Makefile
index 853554b5a0..653c859ba1 100644
--- a/package/system/rpcd/Makefile
+++ b/package/system/rpcd/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=rpcd
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/rpcd.git
diff --git a/package/system/rpcd/files/rpcd.init b/package/system/rpcd/files/rpcd.init
index 447133c67a..3e9ea5bbf3 100755
--- a/package/system/rpcd/files/rpcd.init
+++ b/package/system/rpcd/files/rpcd.init
@@ -12,6 +12,7 @@ start_service() {
procd_open_instance
procd_set_param command "$PROG" ${socket:+-s "$socket"} ${timeout:+-t "$timeout"}
+ procd_set_param respawn ${respawn_retry:-0}
procd_close_instance
}