aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorKonstantin Demin <rockdrilla@gmail.com>2020-11-25 02:59:59 +0300
committerPetr Štetiar <ynezz@true.cz>2020-12-11 13:48:24 +0100
commit42eff7c7e677f6bbc15da1215db664c0e5d260da (patch)
tree320a633db07a72af00d0297971e080383e8253a3 /package
parent7e122c353ae7f1e5c546ada94b6d2c3025bee0fe (diff)
downloadupstream-42eff7c7e677f6bbc15da1215db664c0e5d260da.tar.gz
upstream-42eff7c7e677f6bbc15da1215db664c0e5d260da.tar.bz2
upstream-42eff7c7e677f6bbc15da1215db664c0e5d260da.zip
dropbear: reorder options in Configure recipe
put static options at first place, then place configurable options. also put DROPBEAR_ECC right before DROPBEAR_ECC_FULL to ease maintainance. Signed-off-by: Konstantin Demin <rockdrilla@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/network/services/dropbear/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/package/network/services/dropbear/Makefile b/package/network/services/dropbear/Makefile
index 727f1c16b0..22befbb0cf 100644
--- a/package/network/services/dropbear/Makefile
+++ b/package/network/services/dropbear/Makefile
@@ -107,27 +107,27 @@ define Build/Configure
echo '#define DEFAULT_PATH "$(TARGET_INIT_PATH)"' >> \
$(PKG_BUILD_DIR)/localoptions.h
- echo '#define DROPBEAR_CURVE25519 $(if $(CONFIG_DROPBEAR_CURVE25519),1,0)' >> \
- $(PKG_BUILD_DIR)/localoptions.h
+ # remove protocol idented software version number
+ $(ESED) 's,^(#define LOCAL_IDENT) .*$$$$,\1 "SSH-2.0-dropbear",g' \
+ $(PKG_BUILD_DIR)/sysoptions.h
- for OPTION in DROPBEAR_ECDSA DROPBEAR_ECDH; do \
- echo "#define $$$$OPTION $(if $(CONFIG_DROPBEAR_ECC),1,0)" >> \
+ # disable legacy/unsafe methods and unused functionality
+ for OPTION in INETD_MODE DROPBEAR_CLI_NETCAT DROPBEAR_DSS DO_MOTD ; do \
+ echo "#define $$$$OPTION 0" >> \
$(PKG_BUILD_DIR)/localoptions.h; \
done
+ echo '#define DROPBEAR_CURVE25519 $(if $(CONFIG_DROPBEAR_CURVE25519),1,0)' >> \
+ $(PKG_BUILD_DIR)/localoptions.h
+
echo '#define DROPBEAR_ED25519 $(if $(CONFIG_DROPBEAR_ED25519),1,0)' >> \
$(PKG_BUILD_DIR)/localoptions.h
echo '#define DROPBEAR_CHACHA20POLY1305 $(if $(CONFIG_DROPBEAR_CHACHA20POLY1305),1,0)' >> \
$(PKG_BUILD_DIR)/localoptions.h
- # remove protocol idented software version number
- $(ESED) 's,^(#define LOCAL_IDENT) .*$$$$,\1 "SSH-2.0-dropbear",g' \
- $(PKG_BUILD_DIR)/sysoptions.h
-
- # disable legacy/unsafe methods and unused functionality
- for OPTION in INETD_MODE DROPBEAR_CLI_NETCAT DROPBEAR_DSS DO_MOTD ; do \
- echo "#define $$$$OPTION 0" >> \
+ for OPTION in DROPBEAR_ECDSA DROPBEAR_ECDH; do \
+ echo "#define $$$$OPTION $(if $(CONFIG_DROPBEAR_ECC),1,0)" >> \
$(PKG_BUILD_DIR)/localoptions.h; \
done