aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-09-23 08:35:50 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-09-23 08:35:50 +0000
commit41838f4585e366aefad4323e73278a4c0418a9e6 (patch)
tree7758a39cc6b69246ee0098d0c4dfe880a1ed131b /package
parent896847d18c86fe4217ce83d103d51750e606c087 (diff)
downloadupstream-41838f4585e366aefad4323e73278a4c0418a9e6.tar.gz
upstream-41838f4585e366aefad4323e73278a4c0418a9e6.tar.bz2
upstream-41838f4585e366aefad4323e73278a4c0418a9e6.zip
base-files: make ip matching in dns add/remove functions more explicit, avoids overmatching pairs like 1.2.3.35 and 1.2.3.3
SVN-Revision: 28291
Diffstat (limited to 'package')
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/lib/network/config.sh4
2 files changed, 3 insertions, 3 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index bae3c79e25..775126aa53 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=base-files
-PKG_RELEASE:=79
+PKG_RELEASE:=80
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=opkg/host
diff --git a/package/base-files/files/lib/network/config.sh b/package/base-files/files/lib/network/config.sh
index 5b349a7387..00e372a1f3 100755
--- a/package/base-files/files/lib/network/config.sh
+++ b/package/base-files/files/lib/network/config.sh
@@ -106,7 +106,7 @@ add_dns() {
local dns
local add
for dns in "$@"; do
- grep -qsF "nameserver $dns" /tmp/resolv.conf.auto || {
+ grep -qsE "^nameserver ${dns//./\\.}$" /tmp/resolv.conf.auto || {
add="${add:+$add }$dns"
echo "nameserver $dns" >> /tmp/resolv.conf.auto
}
@@ -126,7 +126,7 @@ remove_dns() {
[ -f /tmp/resolv.conf.auto ] && {
local dns=$(uci_get_state network "$cfg" resolv_dns)
for dns in $dns; do
- sed -i -e "/^nameserver $dns$/d" /tmp/resolv.conf.auto
+ sed -i -e "/^nameserver ${dns//./\\.}$/d" /tmp/resolv.conf.auto
done
}