aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorClaudio Mignanti <c.mignanti@gmail.com>2010-07-19 21:14:24 +0000
committerClaudio Mignanti <c.mignanti@gmail.com>2010-07-19 21:14:24 +0000
commit3f25930247d307cea06e550058ddfe429e7a9422 (patch)
treee238d57a655da1dab76b3656a400edd8a81f01b8 /package
parent49edb3c342b79913df0fa0b16719e2afcab7cfdc (diff)
downloadupstream-3f25930247d307cea06e550058ddfe429e7a9422.tar.gz
upstream-3f25930247d307cea06e550058ddfe429e7a9422.tar.bz2
upstream-3f25930247d307cea06e550058ddfe429e7a9422.zip
pwm: export the generic pwm api as module
SVN-Revision: 22297
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/other.mk19
1 files changed, 17 insertions, 2 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 3781cbe329..b61b529c75 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -679,11 +679,26 @@ endef
$(eval $(call KernelPackage,wdt-scx200))
+define KernelPackage/pwm
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=PWM generic API
+ KCONFIG:=CONFIG_GENERIC_PWM
+ FILES:=$(LINUX_DIR)/drivers/pwm/pwm.ko
+ AUTOLOAD:=$(call AutoLoad,50,pwm)
+endef
+
+define KernelPackage/pwm/description
+ Kernel module that implement a generic PWM API
+endef
+
+$(eval $(call KernelPackage,pwm))
+
+
define KernelPackage/pwm-gpio
SUBMENU:=$(OTHER_MENU)
TITLE:=PWM over GPIO
- KCONFIG:=CONFIG_GENERIC_PWM \
- CONFIG_GPIO_PWM
+ DEPENDS:=+kmod-pwm
+ KCONFIG:=CONFIG_GPIO_PWM
FILES:=$(LINUX_DIR)/drivers/pwm/gpio-pwm.ko
AUTOLOAD:=$(call AutoLoad,51,gpio-pwm)
endef