aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-09-27 17:25:15 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-10-02 13:50:50 +0200
commit365a639f916b4e9a3771cbaa1271153e111ebde6 (patch)
tree393f459261ef5fec1feb27af7c58aca9d3d420a4 /package
parent7f8a1fc55ef77f7d916114dfbdc9460192600fd1 (diff)
downloadupstream-365a639f916b4e9a3771cbaa1271153e111ebde6.tar.gz
upstream-365a639f916b4e9a3771cbaa1271153e111ebde6.tar.bz2
upstream-365a639f916b4e9a3771cbaa1271153e111ebde6.zip
base-files: add function to remove devicename from LED labels
Currently, we request LED labels in OpenWrt to follow the scheme modelname:color:function However, specifying the modelname at the beginning is actually entirely useless for the devices we support in OpenWrt. In patches subsequent to this one, we will thus remove the modelname from the label definitions on various targets. To migrate the existing definitions from older installations, a migration script needs to be deployed that does modelname:color:function -> color:function e.g. dir-789:green:status -> green:status This patch introduces two functions that do exactly that: For each entry in /etc/config/system, the routine will check whether two (or more) colons are present, and then remove everything up to (and including) the first colon. For now, this will be applied unconditionally, i.e. if the function is called for a device, all labels will be cut like this. However, for a future case of mixed three-part and two-part labels, it should not be too hard to provide a function argument with exceptions to the removal. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'package')
-rw-r--r--package/base-files/Makefile2
-rw-r--r--package/base-files/files/lib/functions/migrations.sh23
2 files changed, 24 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index db9be216e6..3cb3d2034a 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
include $(INCLUDE_DIR)/feeds.mk
PKG_NAME:=base-files
-PKG_RELEASE:=230
+PKG_RELEASE:=231
PKG_FLAGS:=nonshared
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
diff --git a/package/base-files/files/lib/functions/migrations.sh b/package/base-files/files/lib/functions/migrations.sh
index b180a0242f..da10d2be5a 100644
--- a/package/base-files/files/lib/functions/migrations.sh
+++ b/package/base-files/files/lib/functions/migrations.sh
@@ -28,11 +28,34 @@ migrate_led_sysfs() {
done;
}
+remove_devicename_led_sysfs() {
+ local cfg="$1"
+ local sysfs
+ local name
+ local new_sysfs
+
+ config_get sysfs ${cfg} sysfs
+ config_get name ${cfg} name
+
+ echo "${sysfs}" | grep -q ":.*:" || return
+
+ new_sysfs=$(echo ${sysfs} | sed "s/^[^:]*://")
+
+ uci set system.${cfg}.sysfs="${new_sysfs}"
+
+ logger -t led-migration "sysfs option of LED \"${name}\" updated to ${new_sysfs}"
+}
+
migrate_leds() {
config_load system
config_foreach migrate_led_sysfs led "$@"
}
+remove_devicename_leds() {
+ config_load system
+ config_foreach remove_devicename_led_sysfs led
+}
+
migrations_apply() {
local realm="$1"
[ -n "$(uci changes ${realm})" ] && uci -q commit ${realm}