aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2018-05-16 20:00:15 +0200
committerLuka Perkov <luka.perkov@sartura.hr>2019-10-06 21:26:11 +0200
commit34e2526f9fcc4d528a65d264775e989425eb253c (patch)
tree322b015d5767a0d215ed0f458493670cf9979554 /package
parent27bf8abe69f3b048cbcbf9d2e796ecba5f0a42e7 (diff)
downloadupstream-34e2526f9fcc4d528a65d264775e989425eb253c.tar.gz
upstream-34e2526f9fcc4d528a65d264775e989425eb253c.tar.bz2
upstream-34e2526f9fcc4d528a65d264775e989425eb253c.zip
kernel: add kmod-rtc-pcf2127
Add kernel module to support NXP PCF2127 and PCF2129 RTC clocks. Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/other.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index e98b8a9223..3abd1f48f6 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -599,6 +599,22 @@ endef
$(eval $(call KernelPackage,rtc-pcf2123))
+define KernelPackage/rtc-pcf2127
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=NXP PCF2127 and PCF2129 RTC support
+ DEFAULT:=m if ALL_KMODS && RTC_SUPPORT
+ KCONFIG:=CONFIG_RTC_DRV_PCF2127 \
+ CONFIG_RTC_CLASS=y
+ FILES:=$(LINUX_DIR)/drivers/rtc/rtc-pcf2127.ko
+ AUTOLOAD:=$(call AutoProbe,rtc-pcf2127)
+endef
+
+define KernelPackage/rtc-pcf2127/description
+ Kernel module for NXP PCF2127 and PCF2129 RTC chip
+endef
+
+$(eval $(call KernelPackage,rtc-pcf2127))
+
define KernelPackage/rtc-pt7c4338
SUBMENU:=$(OTHER_MENU)
TITLE:=Pericom PT7C4338 RTC support