aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-12-23 09:53:06 +0000
committerNicolas Thill <nico@openwrt.org>2009-12-23 09:53:06 +0000
commit33db8762485ca24756115945d58fa6be2e830bdd (patch)
treed18ba3008e0d11b1879233643df361ad5ec06241 /package
parent214b3c90f3ef142cb59b527d83f1734508adb9a3 (diff)
downloadupstream-33db8762485ca24756115945d58fa6be2e830bdd.tar.gz
upstream-33db8762485ca24756115945d58fa6be2e830bdd.tar.bz2
upstream-33db8762485ca24756115945d58fa6be2e830bdd.zip
disable a few packages failing on pxcab (marking them as BROKEN)
SVN-Revision: 18903
Diffstat (limited to 'package')
-rw-r--r--package/ipset/Makefile2
-rw-r--r--package/mac80211/Makefile2
-rw-r--r--package/madwifi/Makefile2
-rw-r--r--package/siit/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/package/ipset/Makefile b/package/ipset/Makefile
index e7870c5585..4c3409b19b 100644
--- a/package/ipset/Makefile
+++ b/package/ipset/Makefile
@@ -19,7 +19,7 @@ PKG_MD5SUM:=d104007fdf5ea64fef774c22b1c0a97b
include $(INCLUDE_DIR)/package.mk
define Package/ipset/Default
- DEPENDS:= @LINUX_2_6
+ DEPENDS:= @LINUX_2_6 @(!(TARGET_pxcab)||BROKEN)
endef
define Package/ipset
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index 92e0d2b84f..a494d5437c 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -33,7 +33,7 @@ WMENU:=Wireless Drivers
define KernelPackage/mac80211/Default
SUBMENU:=$(WMENU)
URL:=http://linuxwireless.org/
- DEPENDS:=@LINUX_2_6 @!TARGET_avr32 @(!TARGET_ep93xx||BROKEN)
+ DEPENDS:=@LINUX_2_6 @!TARGET_avr32 @(!(TARGET_ep93xx||TARGET_pxcab)||BROKEN)
endef
define KernelPackage/mac80211
diff --git a/package/madwifi/Makefile b/package/madwifi/Makefile
index 16ce30e4c0..79a3b3f874 100644
--- a/package/madwifi/Makefile
+++ b/package/madwifi/Makefile
@@ -161,7 +161,7 @@ define KernelPackage/madwifi
SUBMENU:=Wireless Drivers
TITLE:=Driver for Atheros wireless chipsets
URL:=http://madwifi-project.org/
- DEPENDS:=+wireless-tools @PCI_SUPPORT||TARGET_atheros @!TARGET_avr32 @!TARGET_etrax @!TARGET_sibyte @!TARGET_cobalt @!TARGET_octeon @LINUX_2_6 @(!TARGET_ep93xx||BROKEN)
+ DEPENDS:=+wireless-tools @PCI_SUPPORT||TARGET_atheros @!TARGET_avr32 @!TARGET_etrax @!TARGET_sibyte @!TARGET_cobalt @!TARGET_octeon @LINUX_2_6 @(!(TARGET_ep93xx||TARGET_pxcab)||BROKEN)
FILES:=$(MADWIFI_FILES)
AUTOLOAD:=$(call AutoLoad,50,$(MADWIFI_AUTOLOAD))
endef
diff --git a/package/siit/Makefile b/package/siit/Makefile
index f73e9584e5..5d71ebdb26 100644
--- a/package/siit/Makefile
+++ b/package/siit/Makefile
@@ -16,7 +16,7 @@ include $(INCLUDE_DIR)/package.mk
define KernelPackage/siit
SUBMENU:=Network Devices
TITLE:=Stateless IP ICMP Translation Algorithm
- DEPENDS:=@!LINUX_2_6_31
+ DEPENDS:=@!LINUX_2_6_31 @(!(TARGET_pxcab)||BROKEN)
FILES:=$(PKG_BUILD_DIR)/siit.$(LINUX_KMOD_SUFFIX)
AUTOLOAD:=$(call AutoLoad,50,siit)
endef