aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2015-05-05 13:22:33 +0000
committerSteven Barth <cyrus@openwrt.org>2015-05-05 13:22:33 +0000
commit336fc7a702fdea9e6da9797c7d789949099390d7 (patch)
treeb1f04c6069f0242f2fdea78fa6eb09715c4cb505 /package
parent2a196a68cd2218f26e3cd5dcefe077fe9cb8c894 (diff)
downloadupstream-336fc7a702fdea9e6da9797c7d789949099390d7.tar.gz
upstream-336fc7a702fdea9e6da9797c7d789949099390d7.tar.bz2
upstream-336fc7a702fdea9e6da9797c7d789949099390d7.zip
netsupport: l2tp-ip: only depend on IPv6 if IPv6 support is enabled
Before r45593 kmod-l2tp-ip did not depend on kmod-ipv6. With r45593 support for L2TP IPv6 encapsulation was added and included in the kmod-l2tp-ip package. This change also added the dependency to kmod-ipv6 to kmod-l2tp-ip, regardless of whether the user chose to generally include IPv6 support or not. Change this so L2TP over IPv6 and the resulting dependency to kmod-ipv6 is only included in kmod-l2tp-ip if IPv6 support is enabled. Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 45612
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/netsupport.mk10
1 files changed, 6 insertions, 4 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 7ec3d29792..4483581bf4 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -895,11 +895,13 @@ $(eval $(call KernelPackage,l2tp-eth))
define KernelPackage/l2tp-ip
SUBMENU:=$(NETWORK_SUPPORT_MENU)
- TITLE:=L2TP IP + IPv6 encapsulation for L2TPv3
- DEPENDS:=+kmod-l2tp +kmod-ipv6
+ TITLE:=L2TP IP encapsulation for L2TPv3
+ DEPENDS:=+kmod-l2tp +IPV6:kmod-ipv6
KCONFIG:=CONFIG_L2TP_IP
- FILES:=$(LINUX_DIR)/net/l2tp/l2tp_ip.ko $(LINUX_DIR)/net/l2tp/l2tp_ip6.ko
- AUTOLOAD:=$(call AutoLoad,33,l2tp_ip l2tp_ip6)
+ FILES:= \
+ $(LINUX_DIR)/net/l2tp/l2tp_ip.ko \
+ $(if $(CONFIG_IPV6),$(LINUX_DIR)/net/l2tp/l2tp_ip6.ko)
+ AUTOLOAD:=$(call AutoLoad,33,l2tp_ip $(if $(CONFIG_IPV6),l2tp_ip6))
endef
define KernelPackage/l2tp-ip/description