aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2011-10-01 22:36:47 +0000
committerJohn Crispin <john@openwrt.org>2011-10-01 22:36:47 +0000
commit3233a7f4a2516577bd6c1bff4b83d670589db489 (patch)
treedd3882e9cbd73174bb20659199e810a976a92458 /package
parente477159e409b7f1e344790505f5e09b7f7df4ec1 (diff)
downloadupstream-3233a7f4a2516577bd6c1bff4b83d670589db489.tar.gz
upstream-3233a7f4a2516577bd6c1bff4b83d670589db489.tar.bz2
upstream-3233a7f4a2516577bd6c1bff4b83d670589db489.zip
package I2C_MUX_GPIO
this module was missing from [28334] buildbots timed out as the symbol was not defined SVN-Revision: 28352
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/i2c.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/modules/i2c.mk b/package/kernel/modules/i2c.mk
index f6b1cdff6f..8b1e5a3e49 100644
--- a/package/kernel/modules/i2c.mk
+++ b/package/kernel/modules/i2c.mk
@@ -245,6 +245,21 @@ endef
$(eval $(call KernelPackage,i2c-mux))
+I2C_MUX_GPIO_MODULES:= \
+ CONFIG_I2C_MUX_GPIO:drivers/i2c/muxes/gpio-i2cmux
+
+define KernelPackage/i2c-mux-gpio
+ $(call i2c_defaults,$(I2C_MUX_GPIO_MODULES),51)
+ TITLE:=GPIO-based I2C mux/switches
+ DEPENDS:=kmod-i2c-mux
+endef
+
+define KernelPackage/i2c-mux-gpio/description
+ Kernel modules for GENERIC_GPIO I2C bus mux/switching devices.
+endef
+
+$(eval $(call KernelPackage,i2c-mux-gpio))
+
I2C_MUX_PCA954x_MODULES:= \
CONFIG_I2C_MUX_PCA954x:drivers/i2c/muxes/pca954x