aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-06-14 17:40:52 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-06-14 17:40:52 +0000
commit32055c083363bc317ae2f56a752f81d275013f78 (patch)
tree5c212421717d4c09b89d226067ff747ac632387c /package
parent813635b2c8eaeaa3956d864d714c07268c33f708 (diff)
downloadupstream-32055c083363bc317ae2f56a752f81d275013f78.tar.gz
upstream-32055c083363bc317ae2f56a752f81d275013f78.tar.bz2
upstream-32055c083363bc317ae2f56a752f81d275013f78.zip
samba36: remove host build paths
- fix iconv detection because it adds host paths - disable python detection (host python-config is found) iconv issue is reported by buildbot config.log + replicated locally see config.log in logs.tar.gz python issue observed locally on Arch Linux Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> SVN-Revision: 45953
Diffstat (limited to 'package')
-rw-r--r--package/network/services/samba36/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/package/network/services/samba36/Makefile b/package/network/services/samba36/Makefile
index b39f4840e3..d8b930c989 100644
--- a/package/network/services/samba36/Makefile
+++ b/package/network/services/samba36/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=samba
PKG_VERSION:=3.6.25
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE_URL:=http://ftp.samba.org/pub/samba \
http://ftp.samba.org/pub/samba/stable
@@ -35,7 +35,7 @@ define Package/samba36-server
CATEGORY:=Network
TITLE:=Samba 3.6 SMB/CIFS server
URL:=http://www.samba.org/
- DEPENDS:=+USE_GLIBC:librt
+ DEPENDS:=+USE_GLIBC:librt $(ICONV_DEPENDS)
endef
define Package/samba36-client
@@ -83,7 +83,9 @@ CONFIGURE_VARS += \
samba_cv_have_setreuid=yes \
samba_cv_have_setresuid=yes \
ac_cv_header_zlib_h=no \
- samba_cv_zlib_1_2_3=no
+ samba_cv_zlib_1_2_3=no \
+ ac_cv_path_PYTHON="" \
+ ac_cv_path_PYTHON_CONFIG=""
CONFIGURE_ARGS += \
--exec-prefix=/usr \
@@ -95,6 +97,7 @@ CONFIGURE_ARGS += \
--disable-static \
--disable-swat \
--disable-shared-libs \
+ --with-libiconv="$(ICONV_PREFIX)" \
--with-codepagedir=/etc/samba \
--with-configdir=/etc/samba \
--with-included-iniparser \