aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-07-10 20:21:26 +0100
committerDaniel Golle <daniel@makrotopia.org>2021-07-10 22:13:24 +0100
commit315f52e0f3bfa3d65ad14ca21a696c6d31c4edcd (patch)
treeb8be459bee4154bd79642d254f2ede1c25f03850 /package
parent5e8eaac8c3984fa5860e3b5e97504be54c4fea22 (diff)
downloadupstream-315f52e0f3bfa3d65ad14ca21a696c6d31c4edcd.tar.gz
upstream-315f52e0f3bfa3d65ad14ca21a696c6d31c4edcd.tar.bz2
upstream-315f52e0f3bfa3d65ad14ca21a696c6d31c4edcd.zip
lua: make it easier to detect host-built Lua
Install pkg-config file also for host-build, clean up Lua symlinks. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package')
-rw-r--r--package/utils/lua/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/package/utils/lua/Makefile b/package/utils/lua/Makefile
index d262d1e1fc..e15142d8d2 100644
--- a/package/utils/lua/Makefile
+++ b/package/utils/lua/Makefile
@@ -134,8 +134,12 @@ define Host/Install
INSTALL_TOP="$(STAGING_DIR_HOSTPKG)" \
install
- $(LN) $(STAGING_DIR_HOSTPKG)/bin/lua5.1 $(STAGING_DIR_HOSTPKG)/bin/lua
- $(LN) $(STAGING_DIR_HOSTPKG)/bin/luac5.1 $(STAGING_DIR_HOSTPKG)/bin/luac
+ $(INSTALL_DIR) $(STAGING_DIR_HOSTPKG)/lib/pkgconfig
+ $(CP) $(HOST_BUILD_DIR)/etc/lua.pc $(STAGING_DIR_HOSTPKG)/lib/pkgconfig/lua5.1.pc
+
+ $(LN) lua5.1 $(STAGING_DIR_HOSTPKG)/bin/lua
+ $(LN) luac5.1 $(STAGING_DIR_HOSTPKG)/bin/luac
+ $(LN) lua5.1.pc $(STAGING_DIR_HOSTPKG)/lib/pkgconfig/lua.pc
endef
define Build/InstallDev