aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2016-11-21 17:36:56 +0200
committerFelix Fietkau <nbd@nbd.name>2016-12-20 16:24:21 +0100
commit2b54fa4dff4ec3d428063a46859923a7cc387e0a (patch)
treea943142d08e3fbabb54fe536205cfc57d38034e4 /package
parentb33845b2da7a02393f0814f161befa6cc2d5da7c (diff)
downloadupstream-2b54fa4dff4ec3d428063a46859923a7cc387e0a.tar.gz
upstream-2b54fa4dff4ec3d428063a46859923a7cc387e0a.tar.bz2
upstream-2b54fa4dff4ec3d428063a46859923a7cc387e0a.zip
grub2: do not generate mkfonts at build time
Even though these fonts may not be installed, they seem to be generated at build time. Seems that the configure script re-generated from configure.ac is a bit more annoying than it has to be. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/boot/grub2/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/boot/grub2/Makefile b/package/boot/grub2/Makefile
index 6b96e0a8d1..a9bfaadcf0 100644
--- a/package/boot/grub2/Makefile
+++ b/package/boot/grub2/Makefile
@@ -51,6 +51,9 @@ endef
HOST_BUILD_PREFIX := $(STAGING_DIR_HOST)
+CONFIGURE_VARS += \
+ grub_build_mkfont_excuse="don't want fonts"
+
CONFIGURE_ARGS += \
--target=$(REAL_GNU_TARGET_NAME) \
--disable-werror \
@@ -59,7 +62,11 @@ CONFIGURE_ARGS += \
--disable-libzfs \
--disable-grub-mkfont
+HOST_CONFIGURE_VARS += \
+ grub_build_mkfont_excuse="don't want fonts"
+
HOST_CONFIGURE_ARGS += \
+ --disable-grub-mkfont \
--target=$(REAL_GNU_TARGET_NAME) \
--sbindir="$(STAGING_DIR_HOST)/bin" \
--disable-werror \