aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-02-24 21:04:42 +0100
committerFelix Fietkau <nbd@nbd.name>2018-02-25 16:24:02 +0100
commit28a74f3076aac44f470860332a599f0a15d86687 (patch)
treef1e23652483879d0ad0f884bf6bf08640dad1711 /package
parenta86e6b5a9fb3ea15d5e5f7d41a144c9fe1d4fb79 (diff)
downloadupstream-28a74f3076aac44f470860332a599f0a15d86687.tar.gz
upstream-28a74f3076aac44f470860332a599f0a15d86687.tar.bz2
upstream-28a74f3076aac44f470860332a599f0a15d86687.zip
kernel: remove nf_flow_table hardware offload patch (it is not ready yet)
It also does not have any users yet. It will be addde back when the core API issues have been sorted out Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/netfilter.mk5
1 files changed, 2 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index f296a9096e..f859a67496 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -149,9 +149,8 @@ define KernelPackage/nf-flow
CONFIG_NF_FLOW_TABLE_HW
DEPENDS:=+kmod-nf-conntrack @!LINUX_3_18 @!LINUX_4_4 @!LINUX_4_9
FILES:= \
- $(LINUX_DIR)/net/netfilter/nf_flow_table.ko \
- $(LINUX_DIR)/net/netfilter/nf_flow_table_hw.ko
- AUTOLOAD:=$(call AutoProbe,nf_flow_table nf_flow_table_hw)
+ $(LINUX_DIR)/net/netfilter/nf_flow_table.ko
+ AUTOLOAD:=$(call AutoProbe,nf_flow_table)
endef
$(eval $(call KernelPackage,nf-flow))