aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-11-19 12:42:00 +0000
committerJonas Gorski <jogo@openwrt.org>2014-11-19 12:42:00 +0000
commit276817ca7d84839f5e55ceae1dcbdab47cd0ec78 (patch)
treea63391d9eb937ff9ee4efdcb37c74930c7dc5a3f /package
parent02c6798a0dbb8f182cb6a49d75c7cd21f8462106 (diff)
downloadupstream-276817ca7d84839f5e55ceae1dcbdab47cd0ec78.tar.gz
upstream-276817ca7d84839f5e55ceae1dcbdab47cd0ec78.tar.bz2
upstream-276817ca7d84839f5e55ceae1dcbdab47cd0ec78.zip
kernel: remove gpio-pwm kmod definition
r37490 removed the actual driver but left the kmod definition intact, causing the build system hapily creating an empty package for it. Remove it also to not make it seem as if it still exists. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 43316
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/other.mk16
1 files changed, 0 insertions, 16 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index ce22819887..5d1c2fb348 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -509,22 +509,6 @@ endef
$(eval $(call KernelPackage,pwm))
-define KernelPackage/pwm-gpio
- SUBMENU:=$(OTHER_MENU)
- TITLE:=PWM over GPIO
- DEPENDS:=+kmod-pwm
- KCONFIG:=CONFIG_GPIO_PWM
- FILES:=$(LINUX_DIR)/drivers/pwm/gpio-pwm.ko
- AUTOLOAD:=$(call AutoProbe,gpio-pwm)
-endef
-
-define KernelPackage/pwm-gpio/description
- Kernel module to models a single-channel PWM device using a timer and a GPIO pin
-endef
-
-$(eval $(call KernelPackage,pwm-gpio))
-
-
define KernelPackage/rtc-ds1307
SUBMENU:=$(OTHER_MENU)
TITLE:=Dallas/Maxim DS1307 (and compatible) RTC support