aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorGeorgi Valkov <gvalkov@abv.bg>2021-03-02 12:41:10 +0200
committerDaniel Golle <daniel@makrotopia.org>2021-03-07 21:09:01 +0000
commit24737d85e8cadb6062cff556b7fae29265f326e8 (patch)
tree02e2d32fe6c05a3ef000cc58d65182457d54e7a9 /package
parent9e64e4ce26719ea81637b0e3d9754bd5190f0c21 (diff)
downloadupstream-24737d85e8cadb6062cff556b7fae29265f326e8.tar.gz
upstream-24737d85e8cadb6062cff556b7fae29265f326e8.tar.bz2
upstream-24737d85e8cadb6062cff556b7fae29265f326e8.zip
bpftools: fix param order for install on macOS
Fix: bpftools 5.11.2 does not compile on macOS, because the -m option was placed between src and dst. Corrected by moving -m 644 before src. Signed-off-by: Georgi Valkov <gvalkov@abv.bg>
Diffstat (limited to 'package')
-rw-r--r--package/network/utils/bpftools/patches/200-fix-install-param-order-on-macos.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/network/utils/bpftools/patches/200-fix-install-param-order-on-macos.patch b/package/network/utils/bpftools/patches/200-fix-install-param-order-on-macos.patch
new file mode 100644
index 0000000000..ffb7e2ce52
--- /dev/null
+++ b/package/network/utils/bpftools/patches/200-fix-install-param-order-on-macos.patch
@@ -0,0 +1,11 @@
+--- a/tools/lib/bpf/Makefile
++++ b/tools/lib/bpf/Makefile
+@@ -236,7 +236,7 @@ define do_install
+ if [ ! -d '$(DESTDIR_SQ)$2' ]; then \
+ $(INSTALL) -d -m 755 '$(DESTDIR_SQ)$2'; \
+ fi; \
+- $(INSTALL) $1 $(if $3,-m $3,) '$(DESTDIR_SQ)$2'
++ $(INSTALL) $(if $3,-m $3,) $1 '$(DESTDIR_SQ)$2'
+ endef
+
+ install_lib: all_cmd