aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorKonstantin Demin <rockdrilla@gmail.com>2020-11-25 06:14:30 +0300
committerPetr Štetiar <ynezz@true.cz>2020-12-11 13:48:24 +0100
commit228298290e5de2a1a7404e90aef81ace68273683 (patch)
tree0043f335a53e2223320af6d65116faae02fc56fb /package
parente1bd9645b6aee8fc2ae3b56fb2c4332c4d792b89 (diff)
downloadupstream-228298290e5de2a1a7404e90aef81ace68273683.tar.gz
upstream-228298290e5de2a1a7404e90aef81ace68273683.tar.bz2
upstream-228298290e5de2a1a7404e90aef81ace68273683.zip
dropbear: add ssh-askpass support in configuration
binary size cost is much less than 1k. tested on ath79/generic: bin: 215128 -> 215132 (+4b) ipk: 111183 -> 111494 (+311b) Signed-off-by: Konstantin Demin <rockdrilla@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/network/services/dropbear/Config.in10
-rw-r--r--package/network/services/dropbear/Makefile3
2 files changed, 12 insertions, 1 deletions
diff --git a/package/network/services/dropbear/Config.in b/package/network/services/dropbear/Config.in
index 6aa5a7e4e1..15000eff53 100644
--- a/package/network/services/dropbear/Config.in
+++ b/package/network/services/dropbear/Config.in
@@ -99,4 +99,14 @@ config DROPBEAR_SCP
bool "Build dropbear with scp"
default y
+config DROPBEAR_ASKPASS
+ bool "Enable askpass helper support"
+ default n
+ depends on DROPBEAR_DBCLIENT
+ help
+ This enables support for ssh-askpass helper in dropbear client
+ in order to authenticate on remote hosts.
+
+ Increases binary size by about 0.1 kB (MIPS).
+
endmenu
diff --git a/package/network/services/dropbear/Makefile b/package/network/services/dropbear/Makefile
index 5021c2aee1..af346f44ac 100644
--- a/package/network/services/dropbear/Makefile
+++ b/package/network/services/dropbear/Makefile
@@ -32,7 +32,7 @@ PKG_CONFIG_DEPENDS:= \
CONFIG_DROPBEAR_CURVE25519 CONFIG_DROPBEAR_ZLIB \
CONFIG_DROPBEAR_ED25519 CONFIG_DROPBEAR_CHACHA20POLY1305 \
CONFIG_DROPBEAR_UTMP CONFIG_DROPBEAR_PUTUTLINE \
- CONFIG_DROPBEAR_DBCLIENT CONFIG_DROPBEAR_SCP
+ CONFIG_DROPBEAR_DBCLIENT CONFIG_DROPBEAR_SCP CONFIG_DROPBEAR_ASKPASS
include $(INCLUDE_DIR)/package.mk
@@ -136,6 +136,7 @@ DB_OPT_CONFIG = \
DROPBEAR_ECDH|CONFIG_DROPBEAR_ECC|1|0 \
!!DROPBEAR_ECC_384|CONFIG_DROPBEAR_ECC_FULL|1|0 \
!!DROPBEAR_ECC_521|CONFIG_DROPBEAR_ECC_FULL|1|0 \
+ DROPBEAR_CLI_ASKPASS_HELPER|CONFIG_DROPBEAR_ASKPASS|1|0 \
TARGET_CFLAGS += -DARGTYPE=3 -ffunction-sections -fdata-sections -flto