aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2009-03-23 16:16:22 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2009-03-23 16:16:22 +0000
commit1d970c0035c193407f94de18780b451aa36a71b5 (patch)
tree48cf510e1a1a5580b55cbca5be7c44f4cbfc110d /package
parenta9f1ccc40a0c44717d44b8aafe01d7f25ba46ad2 (diff)
downloadupstream-1d970c0035c193407f94de18780b451aa36a71b5.tar.gz
upstream-1d970c0035c193407f94de18780b451aa36a71b5.tar.bz2
upstream-1d970c0035c193407f94de18780b451aa36a71b5.zip
bump to version 0.6.9. Synced default.config and mini.config with upstream version.
SVN-Revision: 14992
Diffstat (limited to 'package')
-rw-r--r--package/hostapd/Makefile4
-rw-r--r--package/hostapd/files/default.config53
-rw-r--r--package/hostapd/files/mini.config53
3 files changed, 66 insertions, 44 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index e4f3655473..38b14c7e1b 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -9,14 +9,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd
-PKG_VERSION:=0.6.8
+PKG_VERSION:=0.6.9
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://hostap.epitest.fi/releases/
PKG_SOURCE_SUBDIR:=hostapd-$(PKG_VERSION)
PKG_SOURCE_VERSION:=$(PKG_REV)
-PKG_MD5SUM:=4b183183e20af1386017e9f499184ee1
+PKG_MD5SUM:=83630d11fa66ade9091f1b304fccd74c
PKG_BUILD_DEPENDS:=PACKAGE_kmod-madwifi:madwifi PACKAGE_kmod-mac80211:mac80211 PACKAGE_kmod-mac80211:libnl
include $(INCLUDE_DIR)/package.mk
diff --git a/package/hostapd/files/default.config b/package/hostapd/files/default.config
index 2414bd3520..8643a2b0ae 100644
--- a/package/hostapd/files/default.config
+++ b/package/hostapd/files/default.config
@@ -17,29 +17,16 @@ CONFIG_DRIVER_WIRED=y
# Driver interface for madwifi driver
CONFIG_DRIVER_MADWIFI=y
-#CFLAGS += -I../head # change to reflect local setup; directory for madwifi src
+#CFLAGS += -I../../madwifi # change to the madwifi source directory
# Driver interface for Prism54 driver
#CONFIG_DRIVER_PRISM54=y
# Driver interface for drivers using the nl80211 kernel interface
CONFIG_DRIVER_NL80211=y
-# driver_nl80211.c requires a rather new libnl, probably not
-# shipped with your distribution yet
-#LIBNL=/usr/src/libnl
-#CFLAGS += -I$(LIBNL)/include
-#LIBS += -L$(LIBNL)/lib
-
-# Driver interface for drivers using Devicescape IEEE 802.11 stack
-#CONFIG_DRIVER_DEVICESCAPE=y
-# Currently, driver_devicescape.c build requires some additional parameters
-# to be able to include some of the kernel header files. Following lines can
-# be used to set these (WIRELESS_DEV must point to the root directory of the
-# wireless-dev.git tree).
-#WIRELESS_DEV=/usr/src/wireless-dev
-#CFLAGS += -I$(WIRELESS_DEV)/net/mac80211
-# driver_devicescape.c requires a rather new libnl, probably not
-# shipped with your distribution yet
+# driver_nl80211.c requires a rather new libnl (version 1.1) which may not be
+# shipped with your distribution yet. If that is the case, you need to build
+# newer libnl version and point the hostapd build to use it.
#LIBNL=/usr/src/libnl
#CFLAGS += -I$(LIBNL)/include
#LIBS += -L$(LIBNL)/lib
@@ -49,6 +36,9 @@ CONFIG_DRIVER_NL80211=y
#CFLAGS += -I/usr/local/include
#LIBS += -L/usr/local/lib
+# Driver interface for no driver (e.g., RADIUS server only)
+#CONFIG_DRIVER_NONE=y
+
# IEEE 802.11F/IAPP
CONFIG_IAPP=y
@@ -91,6 +81,10 @@ CONFIG_EAP_TTLS=y
# EAP-AKA for the integrated EAP server
#CONFIG_EAP_AKA=y
+# EAP-AKA' for the integrated EAP server
+# This requires CONFIG_EAP_AKA to be enabled, too.
+#CONFIG_EAP_AKA_PRIME=y
+
# EAP-PAX for the integrated EAP server
#CONFIG_EAP_PAX=y
@@ -112,6 +106,17 @@ CONFIG_EAP_TTLS=y
# to add the needed functions.
#CONFIG_EAP_FAST=y
+# Wi-Fi Protected Setup (WPS)
+#CONFIG_WPS=y
+# Enable UPnP support for external WPS Registrars
+#CONFIG_WPS_UPNP=y
+
+# EAP-IKEv2
+#CONFIG_EAP_IKEV2=y
+
+# Trusted Network Connect (EAP-TNC)
+#CONFIG_EAP_TNC=y
+
# PKCS#12 (PFX) support (used to read private key and certificate file from
# a file that usually has extension .p12 or .pfx)
CONFIG_PKCS12=y
@@ -123,11 +128,17 @@ CONFIG_PKCS12=y
# Build IPv6 support for RADIUS operations
CONFIG_IPV6=y
-# IEEE 802.11r/D4.1 (Fast BSS Transition)
-# This enables an experimental implementation of a draft version of
-# IEEE 802.11r. This draft is still subject to change, so it should be noted
-# that this version may not comply with the final standard.
+# IEEE Std 802.11r-2008 (Fast BSS Transition)
#CONFIG_IEEE80211R=y
+# Use the hostapd's IEEE 802.11 authentication (ACL), but without
+# the IEEE 802.11 Management capability (e.g., madwifi or FreeBSD/net80211)
+#CONFIG_DRIVER_RADIUS_ACL=y
+
# IEEE 802.11n (High Throughput) support
CONFIG_IEEE80211N=y
+
+# Remove debugging code that is printing out debug messages to stdout.
+# This can be used to reduce the size of the hostapd considerably if debugging
+# code is not needed.
+#CONFIG_NO_STDOUT_DEBUG=y
diff --git a/package/hostapd/files/mini.config b/package/hostapd/files/mini.config
index e50fb3ce70..37f76d1858 100644
--- a/package/hostapd/files/mini.config
+++ b/package/hostapd/files/mini.config
@@ -17,29 +17,16 @@ CONFIG_DRIVER_WIRED=y
# Driver interface for madwifi driver
CONFIG_DRIVER_MADWIFI=y
-#CFLAGS += -I../head # change to reflect local setup; directory for madwifi src
+#CFLAGS += -I../../madwifi # change to the madwifi source directory
# Driver interface for Prism54 driver
#CONFIG_DRIVER_PRISM54=y
# Driver interface for drivers using the nl80211 kernel interface
CONFIG_DRIVER_NL80211=y
-# driver_nl80211.c requires a rather new libnl, probably not
-# shipped with your distribution yet
-#LIBNL=/usr/src/libnl
-#CFLAGS += -I$(LIBNL)/include
-#LIBS += -L$(LIBNL)/lib
-
-# Driver interface for drivers using Devicescape IEEE 802.11 stack
-#CONFIG_DRIVER_DEVICESCAPE=y
-# Currently, driver_devicescape.c build requires some additional parameters
-# to be able to include some of the kernel header files. Following lines can
-# be used to set these (WIRELESS_DEV must point to the root directory of the
-# wireless-dev.git tree).
-#WIRELESS_DEV=/usr/src/wireless-dev
-#CFLAGS += -I$(WIRELESS_DEV)/net/mac80211
-# driver_devicescape.c requires a rather new libnl, probably not
-# shipped with your distribution yet
+# driver_nl80211.c requires a rather new libnl (version 1.1) which may not be
+# shipped with your distribution yet. If that is the case, you need to build
+# newer libnl version and point the hostapd build to use it.
#LIBNL=/usr/src/libnl
#CFLAGS += -I$(LIBNL)/include
#LIBS += -L$(LIBNL)/lib
@@ -49,6 +36,9 @@ CONFIG_DRIVER_NL80211=y
#CFLAGS += -I/usr/local/include
#LIBS += -L/usr/local/lib
+# Driver interface for no driver (e.g., RADIUS server only)
+#CONFIG_DRIVER_NONE=y
+
# IEEE 802.11F/IAPP
CONFIG_IAPP=y
@@ -91,6 +81,10 @@ CONFIG_PEERKEY=y
# EAP-AKA for the integrated EAP server
#CONFIG_EAP_AKA=y
+# EAP-AKA' for the integrated EAP server
+# This requires CONFIG_EAP_AKA to be enabled, too.
+#CONFIG_EAP_AKA_PRIME=y
+
# EAP-PAX for the integrated EAP server
#CONFIG_EAP_PAX=y
@@ -112,6 +106,17 @@ CONFIG_PEERKEY=y
# to add the needed functions.
#CONFIG_EAP_FAST=y
+# Wi-Fi Protected Setup (WPS)
+#CONFIG_WPS=y
+# Enable UPnP support for external WPS Registrars
+#CONFIG_WPS_UPNP=y
+
+# EAP-IKEv2
+#CONFIG_EAP_IKEV2=y
+
+# Trusted Network Connect (EAP-TNC)
+#CONFIG_EAP_TNC=y
+
# PKCS#12 (PFX) support (used to read private key and certificate file from
# a file that usually has extension .p12 or .pfx)
#CONFIG_PKCS12=y
@@ -123,11 +128,17 @@ CONFIG_PEERKEY=y
# Build IPv6 support for RADIUS operations
#CONFIG_IPV6=y
-# IEEE 802.11r/D4.1 (Fast BSS Transition)
-# This enables an experimental implementation of a draft version of
-# IEEE 802.11r. This draft is still subject to change, so it should be noted
-# that this version may not comply with the final standard.
+# IEEE Std 802.11r-2008 (Fast BSS Transition)
#CONFIG_IEEE80211R=y
+# Use the hostapd's IEEE 802.11 authentication (ACL), but without
+# the IEEE 802.11 Management capability (e.g., madwifi or FreeBSD/net80211)
+#CONFIG_DRIVER_RADIUS_ACL=y
+
# IEEE 802.11n (High Throughput) support
CONFIG_IEEE80211N=y
+
+# Remove debugging code that is printing out debug messages to stdout.
+# This can be used to reduce the size of the hostapd considerably if debugging
+# code is not needed.
+#CONFIG_NO_STDOUT_DEBUG=y