aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-07-31 11:42:24 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-07-31 11:42:24 +0000
commit1d7dfee37f357662e740899253857d85c20522e6 (patch)
treeb374ab89f0e248092e17d3dd688699aed01147f6 /package
parent781c091ea5d8e373d247dbe6c667360c8a0f7345 (diff)
downloadupstream-1d7dfee37f357662e740899253857d85c20522e6.tar.gz
upstream-1d7dfee37f357662e740899253857d85c20522e6.tar.bz2
upstream-1d7dfee37f357662e740899253857d85c20522e6.zip
package libipq as a shared library
r21799 by jow changed the staging install of libipq so that it is no longer available as a static library but is dynamically linked in as a shared library. However the libipq package was not being built. This patch provides libipq.so as a package. Signed-off-by: Ashok Rao <greatarbor@gmail.com> SVN-Revision: 22436
Diffstat (limited to 'package')
-rw-r--r--package/iptables/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index 6ba1c2d250..2c5c145bec 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -44,7 +44,7 @@ define Package/iptables
$(call Package/iptables/Default)
TITLE:=IPv4 firewall administration tool
MENU:=1
- DEPENDS+= +kmod-ipt-core +libiptc +libxtables
+ DEPENDS+= +kmod-ipt-core +libiptc +libxtables +libipq
endef
define Package/iptables/description
@@ -272,6 +272,12 @@ define Package/libxtables
TITLE:=IPv4/IPv6 firewall - shared xtables library
endef
+define Package/libipq
+ $(call Package/iptables/Default)
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=IPv4/IPv6 firewall - shared libipq library
+endef
TARGET_CPPFLAGS := \
-I$(PKG_BUILD_DIR)/include \
@@ -372,6 +378,11 @@ define Package/libxtables/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libxtables.so* $(1)/usr/lib/
endef
+define Package/libipq/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libipq.so* $(1)/usr/lib/
+endef
+
define BuildPlugin
define Package/$(1)/install
$(INSTALL_DIR) $$(1)/usr/lib/iptables
@@ -411,3 +422,4 @@ $(eval $(call BuildPackage,ip6tables))
$(eval $(call BuildPackage,ip6tables-utils))
$(eval $(call BuildPackage,libiptc))
$(eval $(call BuildPackage,libxtables))
+$(eval $(call BuildPackage,libipq))