aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-07-17 13:36:13 +0000
committerNicolas Thill <nico@openwrt.org>2010-07-17 13:36:13 +0000
commit1d7a6ebc79e71dbc9085efab8205134bc769159b (patch)
tree3c5f07d5d64407a599065e41ba02fc975bed36ad /package
parent628252073e5673a03643687e16ce887720e49033 (diff)
downloadupstream-1d7a6ebc79e71dbc9085efab8205134bc769159b.tar.gz
upstream-1d7a6ebc79e71dbc9085efab8205134bc769159b.tar.bz2
upstream-1d7a6ebc79e71dbc9085efab8205134bc769159b.zip
dnsmasq: initscript: fix bool options handling, bump release number
SVN-Revision: 22251
Diffstat (limited to 'package')
-rw-r--r--package/dnsmasq/Makefile2
-rw-r--r--package/dnsmasq/files/dnsmasq.init6
2 files changed, 4 insertions, 4 deletions
diff --git a/package/dnsmasq/Makefile b/package/dnsmasq/Makefile
index 852b126fcc..977e109709 100644
--- a/package/dnsmasq/Makefile
+++ b/package/dnsmasq/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dnsmasq
PKG_VERSION:=2.55
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
diff --git a/package/dnsmasq/files/dnsmasq.init b/package/dnsmasq/files/dnsmasq.init
index 49291a5c8a..e2f35e8aad 100644
--- a/package/dnsmasq/files/dnsmasq.init
+++ b/package/dnsmasq/files/dnsmasq.init
@@ -23,8 +23,8 @@ append_bool() {
local option="$2"
local value="$3"
local _loctmp
- config_get_bool _loctmp "$section" "$option"
- [ "$_loctmp" -gt 0 ] && append args "$value"
+ config_get_bool _loctmp "$section" "$option" 0
+ [ $_loctmp -gt 0 ] && append args "$value"
}
append_parm() {
@@ -274,7 +274,7 @@ dhcp_add() {
#check for an already active dhcp server on the interface, unless 'force' is set
config_get_bool force "$cfg" force 0
- [ "$force" -gt 0 ] || {
+ [ $force -gt 0 ] || {
udhcpc -n -q -s /bin/true -t 1 -i $ifname >&- && return 0
}