aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-12-20 18:45:09 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-12-20 18:45:09 +0000
commit1b37ee06f1dc188411f01db9509c4f1cac11e87c (patch)
tree2f4495fb9615306f439725ad5f892916b3c0c4ae /package
parent1d6fbd2e855f78c47133d4401be74b48b3be3488 (diff)
downloadupstream-1b37ee06f1dc188411f01db9509c4f1cac11e87c.tar.gz
upstream-1b37ee06f1dc188411f01db9509c4f1cac11e87c.tar.bz2
upstream-1b37ee06f1dc188411f01db9509c4f1cac11e87c.zip
iptables: don't call autogen.sh, use autoreconf fixup instead of libtool
SVN-Revision: 24740
Diffstat (limited to 'package')
-rw-r--r--package/iptables/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index 6a4e0541e4..597f2bd300 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -19,7 +19,7 @@ PKG_SOURCE_URL:=http://www.netfilter.org/projects/iptables/files \
ftp://ftp.de.netfilter.org/pub/netfilter/iptables/ \
ftp://ftp.no.netfilter.org/pub/netfilter/iptables/
-PKG_FIXUP:=libtool
+PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
@@ -305,11 +305,6 @@ MAKE_FLAGS := \
KERNEL_DIR="$(LINUX_DIR)" PREFIX=/usr \
KBUILD_OUTPUT="$(LINUX_DIR)" \
-define Build/Configure
- (cd $(PKG_BUILD_DIR); ./autogen.sh)
-$(call Build/Configure/Default)
-endef
-
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(INSTALL_DIR) $(1)/usr/include/iptables