aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorIlya Lipnitskiy <ilya.lipnitskiy@gmail.com>2021-02-21 16:03:12 -0800
committerDavid Bauer <mail@david-bauer.net>2021-02-23 20:13:30 +0100
commit17f7b217d3cb61dccbda3300054272c303e408c4 (patch)
tree02dd83d3754e3a72e65e0365bbb15e2e045c3198 /package
parent30b482551d838f0a4a2d0d024a28ac6393f6ab9c (diff)
downloadupstream-17f7b217d3cb61dccbda3300054272c303e408c4.tar.gz
upstream-17f7b217d3cb61dccbda3300054272c303e408c4.tar.bz2
upstream-17f7b217d3cb61dccbda3300054272c303e408c4.zip
wireguard: don't build on Linux 5.10
There are efforts underway to bring wireguard in-tree for Linux 5.4 and to have a common build infrastructure for both 5.4 and 5.10 for kmod-wireguard[0]. Until then, restrict kmod-wireguard to build only on Linux 5.4, because the wireguard-compat package will not build on Linux 5.10. [0]: https://github.com/openwrt/openwrt/pull/3885 Signed-off-by: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/network/services/wireguard/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/network/services/wireguard/Makefile b/package/network/services/wireguard/Makefile
index 91bdb0d7a7..5a4d7ee871 100644
--- a/package/network/services/wireguard/Makefile
+++ b/package/network/services/wireguard/Makefile
@@ -50,7 +50,7 @@ endef
define Package/wireguard
$(call Package/wireguard/Default)
TITLE:=WireGuard meta-package
- DEPENDS:=+wireguard-tools +kmod-wireguard
+ DEPENDS:=+wireguard-tools +kmod-wireguard @LINUX_5_4
endef
include $(INCLUDE_DIR)/kernel-defaults.mk
@@ -73,7 +73,7 @@ define KernelPackage/wireguard
CATEGORY:=Kernel modules
SUBMENU:=Network Support
TITLE:=WireGuard kernel module
- DEPENDS:=+IPV6:kmod-udptunnel6 +kmod-udptunnel4
+ DEPENDS:=+IPV6:kmod-udptunnel6 +kmod-udptunnel4 @LINUX_5_4
FILES:= $(PKG_BUILD_DIR)/src/wireguard.$(LINUX_KMOD_SUFFIX)
AUTOLOAD:=$(call AutoProbe,wireguard)
endef