aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-11-09 11:10:37 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-11-09 11:10:37 +0000
commit10f199d832eeae9768b327fd227c88de108106cf (patch)
tree8478c62fd7777f3d73b4cfcd421d1bff76b9c4e1 /package
parentf371d516bfc14dff62d9dc6b26a5ed0836592d60 (diff)
downloadupstream-10f199d832eeae9768b327fd227c88de108106cf.tar.gz
upstream-10f199d832eeae9768b327fd227c88de108106cf.tar.bz2
upstream-10f199d832eeae9768b327fd227c88de108106cf.zip
firewall: add DHCPv6 default rule (#10381)
SVN-Revision: 28874
Diffstat (limited to 'package')
-rw-r--r--package/firewall/Makefile2
-rw-r--r--package/firewall/files/firewall.config12
2 files changed, 13 insertions, 1 deletions
diff --git a/package/firewall/Makefile b/package/firewall/Makefile
index f95f73b4ad..6106348156 100644
--- a/package/firewall/Makefile
+++ b/package/firewall/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=firewall
PKG_VERSION:=2
-PKG_RELEASE:=41
+PKG_RELEASE:=42
include $(INCLUDE_DIR)/package.mk
diff --git a/package/firewall/files/firewall.config b/package/firewall/files/firewall.config
index 5a5dfd0186..4ba165fcc6 100644
--- a/package/firewall/files/firewall.config
+++ b/package/firewall/files/firewall.config
@@ -43,6 +43,18 @@ config rule
option family ipv4
option target ACCEPT
+# Allow DHCPv6 replies
+# see https://dev.openwrt.org/ticket/10381
+config rule
+ option src wan
+ option proto udp
+ option src_ip fe80::/10
+ option src_port 547
+ option dest_ip fe80::/10
+ option dest_port 546
+ option family ipv6
+ option target ACCEPT
+
# Allow essential incoming IPv6 ICMP traffic
config rule
option src wan