aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-04-13 20:18:26 -0700
committerDaniel Golle <daniel@makrotopia.org>2021-04-15 11:54:14 +0100
commit0ec8c793f5fbecac5c601625a10327bc694e33da (patch)
tree1d292b84f717b111eb76cac0be36d22b419e42b6 /package
parentd6cf997bd77569d8ffa08badb6eecbb817d50e9d (diff)
downloadupstream-0ec8c793f5fbecac5c601625a10327bc694e33da.tar.gz
upstream-0ec8c793f5fbecac5c601625a10327bc694e33da.tar.bz2
upstream-0ec8c793f5fbecac5c601625a10327bc694e33da.zip
libsemanage: fix pkgconfig paths
The pkgconfig file currently points to host paths. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/libs/libsemanage/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/libs/libsemanage/Makefile b/package/libs/libsemanage/Makefile
index ff1519f14e..2fde14c06c 100644
--- a/package/libs/libsemanage/Makefile
+++ b/package/libs/libsemanage/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libsemanage
PKG_VERSION:=3.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/SELinuxProject/selinux/releases/download/3.2
@@ -58,6 +58,8 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libsemanage.pc $(1)/usr/lib/pkgconfig/
+ $(SED) 's,/usr/include,$$$${prefix}/include,g' $(1)/usr/lib/pkgconfig/libsemanage.pc
+ $(SED) 's,/usr/lib,$$$${exec_prefix}/lib,g' $(1)/usr/lib/pkgconfig/libsemanage.pc
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
endef