aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2017-05-10 16:32:05 -0600
committerDaniel Golle <daniel@makrotopia.org>2017-05-17 00:06:52 +0200
commit0dcc36fc7ddecf23b915621c6652dacf75006511 (patch)
tree1085e8c63b11242b40371a57d745e0118c777d31 /package
parent070a46121dff0cf233e4c12f2a5bae6c9300c0eb (diff)
downloadupstream-0dcc36fc7ddecf23b915621c6652dacf75006511.tar.gz
upstream-0dcc36fc7ddecf23b915621c6652dacf75006511.tar.bz2
upstream-0dcc36fc7ddecf23b915621c6652dacf75006511.zip
kernel: add hwmon for W83627EHF and family
Remove support for NCT6775/6 from W83627EHF driver so the NCT6775 driver will still be used for those chips. Signed-off-by: Daniel Golle <daniel@makrotopia.org> Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/hwmon.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 79c81846c6..ed05caeb7f 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -313,6 +313,23 @@ endef
$(eval $(call KernelPackage,hwmon-w83627hf))
+define KernelPackage/hwmon-w83627ehf
+ TITLE:=Winbond W83627EHF/EHG/DHG/UHG, W83667HG monitoring support
+ KCONFIG:=CONFIG_SENSORS_W83627EHF
+ FILES:=$(LINUX_DIR)/drivers/hwmon/w83627ehf.ko
+ AUTOLOAD:=$(call AutoProbe,w83627ehf)
+ $(call AddDepends/hwmon,@TARGET_x86 +kmod-hwmon-vid)
+endef
+
+define KernelPackage/hwmon-w83627ehf/description
+ Kernel module for Winbond W83627EHF/EHG/DHG/UHG and W83667HG thermal monitor chip
+ Support for NCT6775F and NCT6776F has been removed from this driver in favour of
+ using the nct6775 driver to handle those chips.
+endef
+
+$(eval $(call KernelPackage,hwmon-w83627ehf))
+
+
define KernelPackage/hwmon-w83793
TITLE:=Winbond W83793G/R monitoring support
KCONFIG:=CONFIG_SENSORS_W83793