aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-22 17:34:45 +0100
committerFelix Fietkau <nbd@nbd.name>2016-12-24 09:40:46 +0100
commit0d5ba94088efab1701c07c9ab65cdee38e16fcd3 (patch)
treed3f823cdd973d741cb7aec03e96408e3320fe7c1 /package
parent49e81f9fe4bc6f060a74f5505eca2a1767058b0b (diff)
downloadupstream-0d5ba94088efab1701c07c9ab65cdee38e16fcd3.tar.gz
upstream-0d5ba94088efab1701c07c9ab65cdee38e16fcd3.tar.bz2
upstream-0d5ba94088efab1701c07c9ab65cdee38e16fcd3.zip
orion: enable SoC drivers in the kernel config
Clean up packaged modules Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/crypto.mk12
-rw-r--r--package/kernel/linux/modules/i2c.mk17
-rw-r--r--package/kernel/linux/modules/other.mk49
3 files changed, 0 insertions, 78 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index ff19751398..36fb1c31dc 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -661,15 +661,3 @@ define KernelPackage/crypto-xts
endef
$(eval $(call KernelPackage,crypto-xts))
-
-
-define KernelPackage/crypto-mv-cesa
- TITLE:=Marvell crypto engine
- DEPENDS:=+kmod-crypto-manager @TARGET_orion
- KCONFIG:=CONFIG_CRYPTO_DEV_MV_CESA
- FILES:=$(LINUX_DIR)/drivers/crypto/mv_cesa.ko
- AUTOLOAD:=$(call AutoLoad,09,mv_cesa)
- $(call AddDepends/crypto)
-endef
-
-$(eval $(call KernelPackage,crypto-mv-cesa))
diff --git a/package/kernel/linux/modules/i2c.mk b/package/kernel/linux/modules/i2c.mk
index c4767735b9..bfc1171a0c 100644
--- a/package/kernel/linux/modules/i2c.mk
+++ b/package/kernel/linux/modules/i2c.mk
@@ -134,23 +134,6 @@ endef
$(eval $(call KernelPackage,i2c-ibm-iic))
-I2C_MV64XXX_MODULES:=\
- CONFIG_I2C_MV64XXX:drivers/i2c/busses/i2c-mv64xxx
-
-define KernelPackage/i2c-mv64xxx
- $(call i2c_defaults,$(I2C_MV64XXX_MODULES),59)
- TITLE:=Orion Platform I2C interface support
- DEPENDS:=TARGET_orion +kmod-i2c-core
-endef
-
-define KernelPackage/i2c-mv64xxx/description
- Kernel module for I2C interface on the Kirkwood, Orion and Armada XP/370
- family processors
-endef
-
-$(eval $(call KernelPackage,i2c-mv64xxx))
-
-
I2C_TINY_USB_MODULES:= \
CONFIG_I2C_TINY_USB:drivers/i2c/busses/i2c-tiny-usb
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 923a087651..a4f22e406c 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -498,22 +498,6 @@ endef
$(eval $(call KernelPackage,wdt-omap))
-define KernelPackage/wdt-orion
- SUBMENU:=$(OTHER_MENU)
- TITLE:=Marvell Orion Watchdog timer
- DEPENDS:=@TARGET_orion
- KCONFIG:=CONFIG_ORION_WATCHDOG
- FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/orion_wdt.ko
- AUTOLOAD:=$(call AutoLoad,50,orion_wdt,1)
-endef
-
-define KernelPackage/wdt-orion/description
- Kernel module for Marvell Orion, Kirkwood and Armada XP/370 watchdog timer
-endef
-
-$(eval $(call KernelPackage,wdt-orion))
-
-
define KernelPackage/rtc-ds1307
SUBMENU:=$(OTHER_MENU)
TITLE:=Dallas/Maxim DS1307 (and compatible) RTC support
@@ -584,23 +568,6 @@ endef
$(eval $(call KernelPackage,rtc-isl1208))
-define KernelPackage/rtc-marvell
- SUBMENU:=$(OTHER_MENU)
- TITLE:=Marvell SoC built-in RTC support
- DEPENDS:=@RTC_SUPPORT @TARGET_orion
- KCONFIG:=CONFIG_RTC_DRV_MV \
- CONFIG_RTC_CLASS=y
- FILES:=$(LINUX_DIR)/drivers/rtc/rtc-mv.ko
- AUTOLOAD:=$(call AutoProbe,rtc-mv)
-endef
-
-define KernelPackage/rtc-marvell/description
- Kernel module for Marvell SoC built-in RTC.
-endef
-
-$(eval $(call KernelPackage,rtc-marvell))
-
-
define KernelPackage/rtc-pcf8563
SUBMENU:=$(OTHER_MENU)
TITLE:=Philips PCF8563/Epson RTC8564 RTC support
@@ -792,22 +759,6 @@ endef
$(eval $(call KernelPackage,zram))
-define KernelPackage/mvsdio
- SUBMENU:=$(OTHER_MENU)
- TITLE:=Marvell SDIO support
- DEPENDS:=@TARGET_orion +kmod-mmc
- KCONFIG:=CONFIG_MMC_MVSDIO
- FILES:=$(LINUX_DIR)/drivers/mmc/host/mvsdio.ko
- AUTOLOAD:=$(call AutoProbe,mvsdio)
-endef
-
-define KernelPackage/mvsdio/description
- Kernel support for the Marvell SDIO controller
-endef
-
-$(eval $(call KernelPackage,mvsdio))
-
-
define KernelPackage/pps
SUBMENU:=$(OTHER_MENU)
TITLE:=PPS support