aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-07-06 16:10:20 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-07-06 16:10:20 +0000
commit0c1004ac2c4339c564441f47b5644b6f63ef769f (patch)
tree705c26f94aa07c2c92c058ca05d84925f26faade /package
parentde45798d4182e55b2e78c940fd44c3a36c303e7f (diff)
downloadupstream-0c1004ac2c4339c564441f47b5644b6f63ef769f.tar.gz
upstream-0c1004ac2c4339c564441f47b5644b6f63ef769f.tar.bz2
upstream-0c1004ac2c4339c564441f47b5644b6f63ef769f.zip
Add the gpio_keys input module to menuconfig
Signed-off-by: Ferenc Wagner <wferi@niif.hu> SVN-Revision: 16716
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/other.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 74905e1234..fdadfa10e1 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -674,6 +674,23 @@ endef
$(eval $(call KernelPackage,input-polldev))
+define KernelPackage/input-gpio-keys
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=GPIO key support
+ DEPENDS:= @GPIO_SUPPORT +kmod-input-core
+ KCONFIG:=CONFIG_KEYBOARD_GPIO
+ FILES:=$(LINUX_DIR)/drivers/input/keyboard/gpio_keys.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,60,gpio_keys)
+endef
+
+define KernelPackage/input-gpio-keys/description
+ This driver implements support for buttons connected
+ to GPIO pins of various CPUs (and some other chips).
+endef
+
+$(eval $(call KernelPackage,input-gpio-keys))
+
+
define KernelPackage/input-gpio-buttons
SUBMENU:=$(OTHER_MENU)
TITLE:=Polled GPIO buttons input device