aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2017-02-06 15:26:49 -0700
committerFelix Fietkau <nbd@nbd.name>2017-04-03 08:49:16 +0200
commit0b24850e97789818fadcbce4b8de4abc429fd9f2 (patch)
tree4280819eb7e40fbcb4847ad177820b3c5930fdac /package
parent7a5257654c552e2ceeaaafacdff6062f27bd601e (diff)
downloadupstream-0b24850e97789818fadcbce4b8de4abc429fd9f2.tar.gz
upstream-0b24850e97789818fadcbce4b8de4abc429fd9f2.tar.bz2
upstream-0b24850e97789818fadcbce4b8de4abc429fd9f2.zip
busybox: don't install NTP scripts if NTP isn't configured
If you're using Chrony or NTPD you don't want the busybox NTP server as well. Make it's installation truly conditional. Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com> Signed-off-by: Felix Fietkau <nbd@nbd.name> [simplify]
Diffstat (limited to 'package')
-rw-r--r--package/utils/busybox/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/utils/busybox/Makefile b/package/utils/busybox/Makefile
index b75b4551dd..48d945718a 100644
--- a/package/utils/busybox/Makefile
+++ b/package/utils/busybox/Makefile
@@ -112,9 +112,13 @@ endef
define Package/busybox/install
$(INSTALL_DIR) $(1)/etc/init.d
$(CP) $(PKG_INSTALL_DIR)/* $(1)/
+ifneq ($(CONFIG_BUSYBOX_CONFIG_CROND),)
$(INSTALL_BIN) ./files/cron $(1)/etc/init.d/cron
+endif
+ifneq ($(CONFIG_BUSYBOX_CONFIG_NTPD),)
$(INSTALL_BIN) ./files/sysntpd $(1)/etc/init.d/sysntpd
$(INSTALL_BIN) ./files/ntpd-hotplug $(1)/usr/sbin/ntpd-hotplug
+endif
-rm -rf $(1)/lib64
endef