aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-09-22 14:55:17 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-09-22 14:55:17 +0000
commit09fe127a14e396359a1e3daa42472cce6600d5e8 (patch)
tree2ef3ed069c92ae9dceeeba58428fc2644f7a943d /package
parentda94d4ac290799510dccd3bfa1f47db33911726d (diff)
downloadupstream-09fe127a14e396359a1e3daa42472cce6600d5e8.tar.gz
upstream-09fe127a14e396359a1e3daa42472cce6600d5e8.tar.bz2
upstream-09fe127a14e396359a1e3daa42472cce6600d5e8.zip
comgt: perform case insensitive match when probing for Huawei devices (#12039)
SVN-Revision: 33507
Diffstat (limited to 'package')
-rw-r--r--package/comgt/Makefile2
-rw-r--r--package/comgt/files/3g.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/comgt/Makefile b/package/comgt/Makefile
index ae8aa668ba..6cb802c600 100644
--- a/package/comgt/Makefile
+++ b/package/comgt/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=comgt
PKG_VERSION:=0.32
-PKG_RELEASE:=20
+PKG_RELEASE:=21
PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
PKG_SOURCE_URL:=@SF/comgt
diff --git a/package/comgt/files/3g.sh b/package/comgt/files/3g.sh
index 9e44d06650..2ed74b4c08 100644
--- a/package/comgt/files/3g.sh
+++ b/package/comgt/files/3g.sh
@@ -52,7 +52,7 @@ proto_3g_setup() {
export MODE="AT_OPSYS=${CODE}"
elif echo "$cardinfo" | grep -q "Sierra Wireless"; then
SIERRA=1
- elif echo "$cardinfo" | grep -q huawei; then
+ elif echo "$cardinfo" | grep -qi huawei; then
case "$service" in
umts_only) CODE="14,2";;
gprs_only) CODE="13,1";;