aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-09-29 16:27:00 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-09-29 16:27:00 +0000
commit073fca3651354a01848aa126a2fed564b94facb2 (patch)
treebae2ba0688c081a19c1d7fad7541fa13056d3fc2 /package
parent5dc2fe588db82f6ce91303a20d879783581ae8d1 (diff)
downloadupstream-073fca3651354a01848aa126a2fed564b94facb2.tar.gz
upstream-073fca3651354a01848aa126a2fed564b94facb2.tar.bz2
upstream-073fca3651354a01848aa126a2fed564b94facb2.zip
package/grub: fix compile issue under FreeBSD 8.1
SVN-Revision: 23156
Diffstat (limited to 'package')
-rw-r--r--package/grub/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/grub/Makefile b/package/grub/Makefile
index 426b9c3673..f3dd171141 100644
--- a/package/grub/Makefile
+++ b/package/grub/Makefile
@@ -37,6 +37,10 @@ MY_CONFIGURE_ARGS += \
--disable-hercules \
--without-curses \
+ifeq ($(HOST_OS),FreeBSD)
+ MY_CONFIGURE_ARGS += --build=$(GNU_HOST_NAME) --host=$(GNU_TARGET_NAME) --target=$(GNU_TARGET_NAME)
+endif
+
MY_CONFIGURE_VARS += \
grub_cv_prog_objcopy_absolute=yes \