aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2020-10-22 15:02:42 +0100
committerDaniel Golle <daniel@makrotopia.org>2020-10-22 15:13:38 +0100
commit061904d7e339db9cbc966506e1d72b9433bdf353 (patch)
treef154ec2b700683117863f7621be528a3eb41ca59 /package
parentde7ca7dafadfd650d031e0379ce0c002868d5936 (diff)
downloadupstream-061904d7e339db9cbc966506e1d72b9433bdf353.tar.gz
upstream-061904d7e339db9cbc966506e1d72b9433bdf353.tar.bz2
upstream-061904d7e339db9cbc966506e1d72b9433bdf353.zip
uhttpd: adapt defaults for changes ubus.sock path
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package')
-rw-r--r--package/network/services/uhttpd/Makefile2
-rw-r--r--package/network/services/uhttpd/files/ubus.default5
-rw-r--r--package/network/services/uhttpd/files/uhttpd.config2
3 files changed, 7 insertions, 2 deletions
diff --git a/package/network/services/uhttpd/Makefile b/package/network/services/uhttpd/Makefile
index dbade36b0a..83073122e6 100644
--- a/package/network/services/uhttpd/Makefile
+++ b/package/network/services/uhttpd/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uhttpd
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/uhttpd.git
diff --git a/package/network/services/uhttpd/files/ubus.default b/package/network/services/uhttpd/files/ubus.default
index f0f71e9d35..ca9e72a315 100644
--- a/package/network/services/uhttpd/files/ubus.default
+++ b/package/network/services/uhttpd/files/ubus.default
@@ -5,4 +5,9 @@ if [ -z "$(uci -q get uhttpd.main.ubus_prefix)" ]; then
uci commit uhttpd
fi
+[ "$(uci -q get uhttpd.main.ubus_socket)" = "/var/run/ubus.sock" ] && {
+ uci set uhttpd.main.ubus_socket='/var/run/ubus/ubus.sock'
+ uci commit uhttpd
+}
+
exit 0
diff --git a/package/network/services/uhttpd/files/uhttpd.config b/package/network/services/uhttpd/files/uhttpd.config
index 39089ca25b..f368d08e8b 100644
--- a/package/network/services/uhttpd/files/uhttpd.config
+++ b/package/network/services/uhttpd/files/uhttpd.config
@@ -59,7 +59,7 @@ config uhttpd main
# Specify the ubus-rpc prefix and socket path.
# option ubus_prefix /ubus
-# option ubus_socket /var/run/ubus.sock
+# option ubus_socket /var/run/ubus/ubus.sock
# CGI/Lua timeout, if the called script does not
# write data within the given amount of seconds,