aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2018-05-23 09:02:59 +0200
committerJo-Philipp Wich <jo@mein.io>2018-05-23 09:05:55 +0200
commit01c2ce3c7d374c7e00562a7f3e54e87d23fef169 (patch)
tree56dc5500f28015c5bb6194e03ac501d4e8610eb3 /package
parent52809db5446e1c4fbdaa50b703961d036c14bceb (diff)
downloadupstream-01c2ce3c7d374c7e00562a7f3e54e87d23fef169.tar.gz
upstream-01c2ce3c7d374c7e00562a7f3e54e87d23fef169.tar.bz2
upstream-01c2ce3c7d374c7e00562a7f3e54e87d23fef169.zip
uboot-mvebu: fix build on hosts lacking pkg-config
The uboot-mvebu package incorrectly used the host pkg-config for the tool build parts, which broke the build on systems lacking pkg-config and only worked by accident on those that have it installed. Export the host-build specific environment variables for the uboot build to redirect pkg-config invocations to our staged host build pkg-config in buildroot. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package')
-rw-r--r--package/boot/uboot-mvebu/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/boot/uboot-mvebu/Makefile b/package/boot/uboot-mvebu/Makefile
index 3005e45c46..61547acb27 100644
--- a/package/boot/uboot-mvebu/Makefile
+++ b/package/boot/uboot-mvebu/Makefile
@@ -15,6 +15,7 @@ PKG_HASH:=7e7477534409d5368eb1371ffde6820f0f79780a1a1f676161c48442cb303dfd
include $(INCLUDE_DIR)/u-boot.mk
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
define U-Boot/Default
BUILD_TARGET:=mvebu
@@ -31,6 +32,8 @@ endef
UBOOT_TARGETS:= \
clearfog
+Build/Exports:=$(Host/Exports)
+
define Build/Configure
# enable additional options beyond clearfog_defconfig
echo CONFIG_NET_RANDOM_ETHADDR=y >> $(PKG_BUILD_DIR)/configs/$(BUILD_VARIANT)_defconfig