aboutsummaryrefslogtreecommitdiffstats
path: root/package/zram-swap/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-06-21 16:54:37 +0000
committerJohn Crispin <john@openwrt.org>2013-06-21 16:54:37 +0000
commit4ebf19b48fafc8d94e14e4ba779969613b241a6a (patch)
tree9918f890a8915023b49ea30948beb5d048c333fa /package/zram-swap/Makefile
parent44b1688e6c7b4f16f7165fbd560e1183aef69090 (diff)
downloadupstream-4ebf19b48fafc8d94e14e4ba779969613b241a6a.tar.gz
upstream-4ebf19b48fafc8d94e14e4ba779969613b241a6a.tar.bz2
upstream-4ebf19b48fafc8d94e14e4ba779969613b241a6a.zip
packages: clean up the package folder
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 37007
Diffstat (limited to 'package/zram-swap/Makefile')
-rw-r--r--package/zram-swap/Makefile46
1 files changed, 0 insertions, 46 deletions
diff --git a/package/zram-swap/Makefile b/package/zram-swap/Makefile
deleted file mode 100644
index bded5f3808..0000000000
--- a/package/zram-swap/Makefile
+++ /dev/null
@@ -1,46 +0,0 @@
-#
-# Copyright (C) 2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=zram-swap
-PKG_VERSION:=1
-PKG_RELEASE:=2
-
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/zram-swap
- SECTION:=utils
- CATEGORY:=Base system
- DEPENDS:=+kmod-zram +!(BUSYBOX_CONFIG_MKSWAP&&BUSYBOX_CONFIG_SWAPONOFF):swap-utils
- TITLE:=ZRAM swap scripts
- PKGARCH:=all
-endef
-
-define Package/zram-swap/description
- A script to activate swaping on a compressed zram partition. This
- could be used to increase the available memory, by using compressed
- memory.
-endef
-
-define Build/Prepare
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
-endef
-
-define Package/zram-swap/install
- $(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./files/zram.init $(1)/etc/init.d/zram
-endef
-
-$(eval $(call BuildPackage,zram-swap))