aboutsummaryrefslogtreecommitdiffstats
path: root/package/zlib/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-10-20 08:41:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-10-20 08:41:32 +0000
commit9708adb16f7b0b684a6de6eec79ae2b44955f669 (patch)
tree6e37737d71abbb23d5bc23082c26f2d90f0671f3 /package/zlib/Makefile
parentfff7416664a2c6ff153c7ae446b26f8abb492576 (diff)
downloadupstream-9708adb16f7b0b684a6de6eec79ae2b44955f669.tar.gz
upstream-9708adb16f7b0b684a6de6eec79ae2b44955f669.tar.bz2
upstream-9708adb16f7b0b684a6de6eec79ae2b44955f669.zip
zlib: replace -fPIC with $(FPIC)
SVN-Revision: 18093
Diffstat (limited to 'package/zlib/Makefile')
-rw-r--r--package/zlib/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/zlib/Makefile b/package/zlib/Makefile
index 8c7f9f9441..19457c1ac8 100644
--- a/package/zlib/Makefile
+++ b/package/zlib/Makefile
@@ -39,7 +39,7 @@ endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS) -fPIC" \
+ CFLAGS="$(TARGET_CFLAGS) $(FPIC)" \
libz.a libz.so
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \