aboutsummaryrefslogtreecommitdiffstats
path: root/package/wlcompat/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-07 08:34:51 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-07 08:34:51 +0000
commit34bb4638e7eeebcfc901c6a8cc00038fc33e4c7a (patch)
treed03a529733bb0260835cc50a4592b3e9b3f62dde /package/wlcompat/Makefile
parent3e2f44481fc0c353cc53c3a70b8a59d2ce0c6b60 (diff)
downloadupstream-34bb4638e7eeebcfc901c6a8cc00038fc33e4c7a.tar.gz
upstream-34bb4638e7eeebcfc901c6a8cc00038fc33e4c7a.tar.bz2
upstream-34bb4638e7eeebcfc901c6a8cc00038fc33e4c7a.zip
move package description to a separate definition, remove it when DESCRIPTION=TITLE
SVN-Revision: 8659
Diffstat (limited to 'package/wlcompat/Makefile')
-rw-r--r--package/wlcompat/Makefile24
1 files changed, 16 insertions, 8 deletions
diff --git a/package/wlcompat/Makefile b/package/wlcompat/Makefile
index 78e3c0fcfd..482ec4a2d2 100644
--- a/package/wlcompat/Makefile
+++ b/package/wlcompat/Makefile
@@ -19,26 +19,34 @@ define KernelPackage/wlcompat/Default
SUBMENUDEP:=@TARGET_BRCM_2_4
DEPENDS:=@TARGET_BRCM_2_4 @PACKAGE_kmod-brcm-wl||PACKAGE_kmod-brcm-wl-mimo +wireless-tools
TITLE:=Broadcom wl wrapper module
- DESCRIPTION:=\
- This package contains a wrapper module, that provides Wireless Extension \\\
- support for the proprietary Broadcom wl module.
+endef
+
+define KernelPackage/wlcompat/Default/description
+ This package contains a wrapper module, that provides Wireless Extension
+ support for the proprietary Broadcom wl module.
endef
define KernelPackage/wlcompat
- $(call KernelPackage/wlcompat/Default)
+$(call KernelPackage/wlcompat/Default)
FILES:=$(PKG_BUILD_DIR)/wlcompat.o
AUTOLOAD:=$(call AutoLoad,50,wlcompat)
endef
+define KernelPackage/wlcompat/description
+$(call KernelPackage/wlcompat/Default/description)
+endef
+
define KernelPackage/wlcompat-debug
- $(call KernelPackage/wlcompat/Default)
+$(call KernelPackage/wlcompat/Default)
TITLE+= (debug)
- DESCRIPTION+=\\\
- \\\
- This is a debugging version.
FILES:=$(PKG_BUILD_DIR)/wlcompat-debug.o
endef
+define KernelPackage/wlcompat-debug/description
+$(call KernelPackage/wlcompat/Default/description)
+ This is a debugging version.
+endef
+
define Build/Prepare
mkdir -p $(PKG_BUILD_DIR)
$(CP) ./src/* $(PKG_BUILD_DIR)/