aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-01-02 15:56:25 -0800
committerPaul Spooren <mail@aparcar.org>2021-01-06 15:38:57 -1000
commit980dca6b7f657846a74b2e069ee120014a4c4137 (patch)
tree34e732c63ec02e3edb33dca511aa600dbec0b032 /package/utils
parentcd5f66652bd405872fc33ca6410dc8f9b51fee09 (diff)
downloadupstream-980dca6b7f657846a74b2e069ee120014a4c4137.tar.gz
upstream-980dca6b7f657846a74b2e069ee120014a4c4137.tar.bz2
upstream-980dca6b7f657846a74b2e069ee120014a4c4137.zip
lua: add -ldl for glibc builds
For glibc, lua needs an explicit link to libdl as glibc has it separate Fixes the following error in at least collectd: ld: usr/lib/liblua.so: undefined reference to `dlopen' ld: usr/lib/liblua.so: undefined reference to `dlclose' ld: usr/lib/liblua.so: undefined reference to `dlerror' ld: usr/lib/liblua.so: undefined reference to `dlsym' Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/utils')
-rw-r--r--package/utils/lua/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/utils/lua/Makefile b/package/utils/lua/Makefile
index 3cdb2bcdb6..a54ef7d25a 100644
--- a/package/utils/lua/Makefile
+++ b/package/utils/lua/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=lua
PKG_VERSION:=5.1.5
-PKG_RELEASE:=7
+PKG_RELEASE:=8
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.lua.org/ftp/ \
@@ -99,7 +99,7 @@ define Build/Compile
RANLIB="$(TARGET_CROSS)ranlib" \
INSTALL_ROOT=/usr \
CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
- MYLDFLAGS="$(TARGET_LDFLAGS) $(if $(CONFIG_USE_GLIBC),-lm)" \
+ MYLDFLAGS="$(TARGET_LDFLAGS) $(if $(CONFIG_USE_GLIBC),-lm -ldl)" \
PKG_VERSION=$(PKG_VERSION) \
linux
rm -rf $(PKG_INSTALL_DIR)