aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-08-29 21:37:29 -1000
committerDaniel Golle <daniel@makrotopia.org>2020-08-31 10:19:31 +0100
commit976d3e22349c9da607777ad364c8639b5c531e04 (patch)
treee83ac371ada392e3ce2fbfd4129f83aae0ded401 /package/utils
parent7078294b59ccbbddf641f80efa743095ca275530 (diff)
downloadupstream-976d3e22349c9da607777ad364c8639b5c531e04.tar.gz
upstream-976d3e22349c9da607777ad364c8639b5c531e04.tar.bz2
upstream-976d3e22349c9da607777ad364c8639b5c531e04.zip
px5g: rename to px5g-mbedtls
Two versions of `px5g` exists without sharing code. For clarification rename the previously existing MbedTLS based version to `px5g-mbedtls` to exists next to `px5g-wolfssl`. Rename code file of MbedTLS from `px5g.c` to `px5g-mbedtls.c`. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'package/utils')
-rw-r--r--package/utils/px5g-mbedtls/Makefile (renamed from package/utils/px5g/Makefile)4
-rw-r--r--package/utils/px5g-mbedtls/px5g-mbedtls.c (renamed from package/utils/px5g/px5g.c)0
2 files changed, 2 insertions, 2 deletions
diff --git a/package/utils/px5g/Makefile b/package/utils/px5g-mbedtls/Makefile
index f4be6cb5ee..42ffd39ce3 100644
--- a/package/utils/px5g/Makefile
+++ b/package/utils/px5g-mbedtls/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
-PKG_NAME:=px5g
+PKG_NAME:=px5g-mbedtls
PKG_RELEASE:=9
PKG_LICENSE:=LGPL-2.1
@@ -55,7 +55,7 @@ endif
TARGET_CFLAGS += -Wl,--gc-sections -Wall -Werror
define Build/Compile
- $(TARGET_CC) $(TARGET_CPPFLAGS) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/px5g px5g.c $(TARGET_LDFLAGS)
+ $(TARGET_CC) $(TARGET_CPPFLAGS) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/px5g px5g-mbedtls.c $(TARGET_LDFLAGS)
endef
define Package/px5g-mbedtls/install
diff --git a/package/utils/px5g/px5g.c b/package/utils/px5g-mbedtls/px5g-mbedtls.c
index 0b72154509..0b72154509 100644
--- a/package/utils/px5g/px5g.c
+++ b/package/utils/px5g-mbedtls/px5g-mbedtls.c