aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-09-01 15:37:03 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2020-09-06 23:19:12 +0200
commit83e946d7183f6123fd8da492652a6aad1fb414fa (patch)
treea9129f13650a07359f43e3d17d97506d22fc8044 /package/utils
parent787de4331f0b01da114f16fcfaea5ecdfc010310 (diff)
downloadupstream-83e946d7183f6123fd8da492652a6aad1fb414fa.tar.gz
upstream-83e946d7183f6123fd8da492652a6aad1fb414fa.tar.bz2
upstream-83e946d7183f6123fd8da492652a6aad1fb414fa.zip
util-linux: Fix build when libmagic is present
When the libmagic from the file package in the packages feed was also compiled and provided its libmagic.so file, util-linux tried to link against it. Avoid this by explicitly disable libmagic support. This fixes the following build error: Package more is missing dependencies for the following libraries: libmagic.so.1 Fixes: 36d9ed360a34 ("util-linux: update to 2.36") Acked-by: Sebastian Kemper <sebastian_ml@gmx.net> Signed-off-by: Rosen Penev <rosenp@gmail.com> [Add commit description] Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/utils')
-rw-r--r--package/utils/util-linux/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/utils/util-linux/Makefile b/package/utils/util-linux/Makefile
index 0fc9819c58..05ceaa413e 100644
--- a/package/utils/util-linux/Makefile
+++ b/package/utils/util-linux/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=util-linux
PKG_VERSION:=2.36
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.36
@@ -526,6 +526,7 @@ CONFIGURE_ARGS += \
--without-python \
--without-udev \
--without-readline \
+ --without-libmagic \
--with-ncursesw
TARGET_CFLAGS += $(FPIC) -std=gnu99