aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2021-06-06 18:15:08 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2021-06-13 23:58:15 +0200
commit72cc44958ef4e0df1a152178514c92899d6a957a (patch)
tree159a65a3469cf15067e5286b2658abfae8147307 /package/utils
parent0b92b5b04f4bd1438be2720c202119d42e8876f3 (diff)
downloadupstream-72cc44958ef4e0df1a152178514c92899d6a957a.tar.gz
upstream-72cc44958ef4e0df1a152178514c92899d6a957a.tar.bz2
upstream-72cc44958ef4e0df1a152178514c92899d6a957a.zip
treewide: mark selected packages nonshared
Mark uci, ubus, libubox, lua, libnl-tiny and libjson-c as nonshared packages. This helps to keep coherent dependencies if these ABI versioned packages are later updated. Before this commit it is possible to get missing dependencies in target-specific nonshared packages (like iwinfo) that depend on these shared ABI versioned packages. If these are later updated and rebuilt, only the new ABI version will be available for download, while the target-specific packages in releases continue to depend on the old ABI version. After this commit the packages are built along the other nonshared packages by the phase1 images buildbot and will be available at the target/ download directories instead of packages/base dir. That will help to keep a coherent set available. Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Diffstat (limited to 'package/utils')
-rw-r--r--package/utils/lua/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/utils/lua/Makefile b/package/utils/lua/Makefile
index a54ef7d25a..83b83e4856 100644
--- a/package/utils/lua/Makefile
+++ b/package/utils/lua/Makefile
@@ -9,13 +9,14 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=lua
PKG_VERSION:=5.1.5
-PKG_RELEASE:=8
+PKG_RELEASE:=9
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.lua.org/ftp/ \
http://www.tecgraf.puc-rio.br/lua/ftp/
PKG_HASH:=2640fc56a795f29d28ef15e13c34a47e223960b0240e8cb0a82d9b0738695333
PKG_BUILD_PARALLEL:=1
+PKG_FLAGS := nonshared
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=COPYRIGHT