aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils
diff options
context:
space:
mode:
authorHuangbin Zhan <zhanhb88@gmail.com>2020-06-10 07:11:08 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2020-06-26 20:54:53 +0200
commit67575b64107d39096195aaaa13b2c2986a5ff97f (patch)
tree210c2b496080b5b0828a38971a18c783548ff9d6 /package/utils
parent5596452cd4c48e806d7060badb1a106102af57d6 (diff)
downloadupstream-67575b64107d39096195aaaa13b2c2986a5ff97f.tar.gz
upstream-67575b64107d39096195aaaa13b2c2986a5ff97f.tar.bz2
upstream-67575b64107d39096195aaaa13b2c2986a5ff97f.zip
logger: enable alternatives support
Avoid conflict with busybox Signed-off-by: Huangbin Zhan <zhanhb88@gmail.com>
Diffstat (limited to 'package/utils')
-rw-r--r--package/utils/util-linux/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/utils/util-linux/Makefile b/package/utils/util-linux/Makefile
index 77b4b98b56..3953d83238 100644
--- a/package/utils/util-linux/Makefile
+++ b/package/utils/util-linux/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=util-linux
PKG_VERSION:=2.35.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.35
@@ -267,6 +267,7 @@ endef
define Package/logger
$(call Package/util-linux/Default)
TITLE:=a shell command interface to the syslog system log module
+ ALTERNATIVES:=200:/usr/bin/logger:/usr/bin/util-linux-logger
endef
define Package/logger/description
@@ -659,7 +660,7 @@ endef
define Package/logger/install
$(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/logger $(1)/usr/bin/
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/logger $(1)/usr/bin/util-linux-logger
endef
define Package/look/install