aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/usbreset/Makefile
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-12-30 18:35:30 -1000
committerPaul Spooren <mail@aparcar.org>2021-01-03 13:00:34 -1000
commit6cda95431984312d15032f6466b3b7238936185b (patch)
tree1e7b265aa1f37ac2e9bc52785a04bc6799b53db7 /package/utils/usbreset/Makefile
parent22e568d0fe5d44246874d3300e7e714f7594c320 (diff)
downloadupstream-6cda95431984312d15032f6466b3b7238936185b.tar.gz
upstream-6cda95431984312d15032f6466b3b7238936185b.tar.bz2
upstream-6cda95431984312d15032f6466b3b7238936185b.zip
usbreset: remove redundant package
The package `usbutils` already offers an USB reset function, this package is therefore not really required standalone. CC: Jo-Philipp Wich <jo@mein.io> Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'package/utils/usbreset/Makefile')
-rw-r--r--package/utils/usbreset/Makefile39
1 files changed, 0 insertions, 39 deletions
diff --git a/package/utils/usbreset/Makefile b/package/utils/usbreset/Makefile
deleted file mode 100644
index bf3160cb1a..0000000000
--- a/package/utils/usbreset/Makefile
+++ /dev/null
@@ -1,39 +0,0 @@
-#
-# Copyright (C) 2011-2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=usbreset
-PKG_RELEASE:=5
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/usbreset
- SECTION:=utils
- CATEGORY:=Utilities
- TITLE:=Utility to send a USB port reset to a USB device
- MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
-endef
-
-define Package/usbreset/description
- This package contains the small usbreset utility which
- can be used to send a USB port reset to a USB device -
- useful for debugging or to force re-detection of particular
- devices.
-endef
-
-define Build/Compile
- $(TARGET_CC) $(TARGET_CFLAGS) -Wall \
- -o $(PKG_BUILD_DIR)/usbreset $(PKG_BUILD_DIR)/usbreset.c
-endef
-
-define Package/usbreset/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/usbreset $(1)/usr/bin/
-endef
-
-$(eval $(call BuildPackage,usbreset))