aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/ugps
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2017-03-05 19:30:44 +0100
committerPiotr Dymacz <pepe2k@gmail.com>2017-03-08 13:32:24 +0100
commitb6e3b7079097ccce6262891f9f1130bea3879aad (patch)
treed9ed3ab7cd80ad327f6bc72df5c74baa9a78654a /package/utils/ugps
parent318f2d61016e69206ab9ec63017eb47e246c0b75 (diff)
downloadupstream-b6e3b7079097ccce6262891f9f1130bea3879aad.tar.gz
upstream-b6e3b7079097ccce6262891f9f1130bea3879aad.tar.bz2
upstream-b6e3b7079097ccce6262891f9f1130bea3879aad.zip
ugps: fix and improve init script
The ugps tool expects device path in last argument. If it's provided before other options, they won't be processed at all. Additionally, make it possible to use absolute path for gps character device in related uci configuration. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'package/utils/ugps')
-rw-r--r--package/utils/ugps/Makefile2
-rw-r--r--package/utils/ugps/files/ugps.init8
2 files changed, 7 insertions, 3 deletions
diff --git a/package/utils/ugps/Makefile b/package/utils/ugps/Makefile
index 8744300c50..1dad863fd8 100644
--- a/package/utils/ugps/Makefile
+++ b/package/utils/ugps/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ugps
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE_URL=$(LEDE_GIT)/project/ugps.git
PKG_SOURCE_PROTO:=git
diff --git a/package/utils/ugps/files/ugps.init b/package/utils/ugps/files/ugps.init
index a7a88c2258..157043cc28 100644
--- a/package/utils/ugps/files/ugps.init
+++ b/package/utils/ugps/files/ugps.init
@@ -14,11 +14,15 @@ start_service() {
local tty="$(uci get gps.@gps[-1].tty)"
local atime="$(uci get gps.@gps[-1].adjust_time)"
- [ -d "/sys/class/tty/$tty/" ] || return
+ [ -c "$tty" ] || {
+ tty="/dev/$tty"
+ [ -c "$tty" ] || return
+ }
procd_open_instance
- procd_set_param command "$PROG" "/dev/$tty"
+ procd_set_param command "$PROG"
[ "$atime" -eq 0 ] || procd_append_param command "-a"
+ procd_append_param command "$tty"
procd_set_param respawn
procd_close_instance
}