aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/ugps
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2015-04-02 14:53:00 +0000
committerNicolas Thill <nico@openwrt.org>2015-04-02 14:53:00 +0000
commit275df67b6cd5954061f7fe8b9ca97499ebc198f7 (patch)
tree750a90b98da0345eefe3dbc2377f7af370d65c0d /package/utils/ugps
parent2bd178c175bb4173e8745149326ccad8f8cb1f25 (diff)
downloadupstream-275df67b6cd5954061f7fe8b9ca97499ebc198f7.tar.gz
upstream-275df67b6cd5954061f7fe8b9ca97499ebc198f7.tar.bz2
upstream-275df67b6cd5954061f7fe8b9ca97499ebc198f7.zip
ugps: add conffiles section, fix config file perms
Signed-off-by: Nicolas Thill <nico@openwrt.org> SVN-Revision: 45240
Diffstat (limited to 'package/utils/ugps')
-rw-r--r--package/utils/ugps/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/utils/ugps/Makefile b/package/utils/ugps/Makefile
index 3662125c3a..b724f6189d 100644
--- a/package/utils/ugps/Makefile
+++ b/package/utils/ugps/Makefile
@@ -36,11 +36,15 @@ ifneq ($(CONFIG_USE_GLIBC),)
TARGET_CFLAGS += -D_DEFAULT_SOURCE
endif
+define Package/ugps/conffiles
+/etc/config/gps
+endef
+
define Package/ugps/install
$(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/init.d $(1)/etc/config
$(INSTALL_BIN) $(PKG_BUILD_DIR)/ugps $(1)/usr/sbin/
$(INSTALL_BIN) ./files/ugps.init $(1)/etc/init.d/ugps
- $(INSTALL_BIN) ./files/gps.config $(1)/etc/config/gps
+ $(INSTALL_CONF) ./files/gps.config $(1)/etc/config/gps
endef
$(eval $(call BuildPackage,ugps))