aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/spidev_test/Makefile
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2019-05-10 23:31:01 +0200
committerChristian Lamparter <chunkeey@gmail.com>2019-05-11 16:37:11 +0200
commitbdaaf66e28bd45837e420ac2300df108091ec97a (patch)
treeb0a2f49543c960f6dc086736cc0bc9e7a26b912a /package/utils/spidev_test/Makefile
parentd8ec6dee49cb1389c2babdbb0bdb9e14d2bbe899 (diff)
downloadupstream-bdaaf66e28bd45837e420ac2300df108091ec97a.tar.gz
upstream-bdaaf66e28bd45837e420ac2300df108091ec97a.tar.bz2
upstream-bdaaf66e28bd45837e420ac2300df108091ec97a.zip
utils/spidev_test: build package directly from Linux
Jeff Kletsky noted in his patch titled: "utils/spidev_test: Update to current source from upstream Linux" that the spidev_test utility OpenWrt ships is severly out of date. Instead of updating the spidev_test.c from the current kernel, this patch replaces the package building code to utilize the very file that gets shipped with the kernel we compiling for anyway much like the "perf" package already does. Reported-by: Jeff Kletsky <git-commits@allycomm.com> Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'package/utils/spidev_test/Makefile')
-rw-r--r--package/utils/spidev_test/Makefile26
1 files changed, 23 insertions, 3 deletions
diff --git a/package/utils/spidev_test/Makefile b/package/utils/spidev_test/Makefile
index b7c5227f91..29c6a90dc8 100644
--- a/package/utils/spidev_test/Makefile
+++ b/package/utils/spidev_test/Makefile
@@ -10,13 +10,16 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=spidev-test
PKG_RELEASE:=$(LINUX_VERSION)
+PKG_FLAGS:=nonshared
+PKG_BUILD_DIR:=$(LINUX_DIR)/tools/spi-$(TARGET_DIR_NAME)
+PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
define Package/spidev-test
SECTION:=utils
CATEGORY:=Utilities
- DEPENDS:=+kmod-spi-dev
+ DEPENDS:=+kmod-spi-dev @!IN_SDK
TITLE:=SPI testing utility
VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
URL:=http://www.kernel.org
@@ -27,9 +30,26 @@ define Package/spidev-test/description
SPI testing utility.
endef
+define Build/Prepare
+ $(CP) $(LINUX_DIR)/tools/spi/* $(PKG_BUILD_DIR)/
+endef
+
+MAKE_FLAGS = \
+ ARCH="$(LINUX_KARCH)" \
+ CROSS_COMPILE="$(TARGET_CROSS)" \
+ CC="$(TARGET_CC)" \
+ LD="$(TARGET_CROSS)ld" \
+ CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
+ LDFLAGS="$(TARGET_LDFLAGS)" \
+ $(if $(findstring c,$(OPENWRT_VERBOSE)),V=1,V='') \
+ WERROR=0 \
+ prefix=/usr
+
define Build/Compile
- $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/spidev_test \
- $(PKG_BUILD_DIR)/spidev_test.c
+ +$(MAKE_FLAGS) $(MAKE) $(PKG_JOBS) \
+ -C $(PKG_BUILD_DIR) \
+ -f Makefile \
+ --no-print-directory
endef
define Package/spidev-test/install