aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/spidev_test/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2016-06-30 13:05:22 +0200
committerJohn Crispin <john@phrozen.org>2016-06-30 22:48:39 +0200
commit97c90557a9f5a6edf9cb0e9b51e7e6d0830ce34d (patch)
tree88ff692c728aee9f6b3b122486d8a5acd55bce0a /package/utils/spidev_test/Makefile
parent66b67b743ffa2a55b64aeda4fe5e54da33227f43 (diff)
downloadupstream-97c90557a9f5a6edf9cb0e9b51e7e6d0830ce34d.tar.gz
upstream-97c90557a9f5a6edf9cb0e9b51e7e6d0830ce34d.tar.bz2
upstream-97c90557a9f5a6edf9cb0e9b51e7e6d0830ce34d.zip
spidev_test: copy the source code into the package folder
Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'package/utils/spidev_test/Makefile')
-rw-r--r--package/utils/spidev_test/Makefile12
1 files changed, 2 insertions, 10 deletions
diff --git a/package/utils/spidev_test/Makefile b/package/utils/spidev_test/Makefile
index 631ef0dd24..e92bf63ccb 100644
--- a/package/utils/spidev_test/Makefile
+++ b/package/utils/spidev_test/Makefile
@@ -28,20 +28,12 @@ define Package/spidev-test/description
endef
define Build/Prepare
+ $(CP) src/spidev_test.c $(PKG_BUILD_DIR)/
endef
-# requires 214-spidev_h_portability.patch
-# or linux/ioctl.h include on musl
define Build/Compile
-
-ifneq ($(CONFIG_LINUX_3_18)$(CONFIG_LINUX_4_1)$(CONFIG_LINUX_4_4),y)
- $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/spidev_test \
- $(LINUX_DIR)/tools/spi/spidev_test.c
-else
$(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/spidev_test \
- $(LINUX_DIR)/Documentation/spi/spidev_test.c
-endif
-
+ $(PKG_BUILD_DIR)/spidev_test.c
endef
define Package/spidev-test/install