aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/px5g/Makefile
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2019-08-05 15:34:38 -0300
committerChristian Lamparter <chunkeey@gmail.com>2019-09-01 00:34:30 +0200
commita552ababd4ff8e91d3f03f7496f12d080a71ba28 (patch)
tree6686d7751613d33f1ef7a3d4a6414b1253fb7245 /package/utils/px5g/Makefile
parentf40262697f5aebed25313a1b2eb8f68d37c97e60 (diff)
downloadupstream-a552ababd4ff8e91d3f03f7496f12d080a71ba28.tar.gz
upstream-a552ababd4ff8e91d3f03f7496f12d080a71ba28.tar.bz2
upstream-a552ababd4ff8e91d3f03f7496f12d080a71ba28.zip
px5g: support EC keys
This adds an 'eckey' command to generate an EC key, with an optional curve name argument, with P-256 as default. For the 'selfsigned' command, it adds an 'ec' algorithm argument to the '-newkey' option, and a '-pkeyopt ec_paramgen_curve:<curvename>' option, mirroring the way openssl specifies the curve name. Notice that curve names are not necessarily the same in mbedtls and openssl. In particular, secp256r1 works for mbedtls, but openssl uses prime256v1 instead. px5g uses mbedtls, but short NIST curve names P-256 and P-384 are specifically supported. Package size increased by about 900 bytes (arm). Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Diffstat (limited to 'package/utils/px5g/Makefile')
-rw-r--r--package/utils/px5g/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/utils/px5g/Makefile b/package/utils/px5g/Makefile
index 592d19663d..f4be6cb5ee 100644
--- a/package/utils/px5g/Makefile
+++ b/package/utils/px5g/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=px5g
-PKG_RELEASE:=8
+PKG_RELEASE:=9
PKG_LICENSE:=LGPL-2.1
PKG_USE_MIPS16:=0
@@ -52,7 +52,7 @@ ifeq ($(BUILD_VARIANT),standalone)
TARGET_LDFLAGS := -Wl,-Bstatic $(TARGET_LDFLAGS) -Wl,-Bdynamic
endif
-TARGET_CFLAGS += -Wl,--gc-sections
+TARGET_CFLAGS += -Wl,--gc-sections -Wall -Werror
define Build/Compile
$(TARGET_CC) $(TARGET_CPPFLAGS) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/px5g px5g.c $(TARGET_LDFLAGS)