aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/px5g-wolfssl
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-08-31 10:55:04 -1000
committerDaniel Golle <daniel@makrotopia.org>2020-08-31 22:29:37 +0100
commit18b1cc283879c39ffe6b50d18b487448162f2139 (patch)
treef09007e0bb6d1bc496c1bb48db58574b98f6d841 /package/utils/px5g-wolfssl
parent2e2425ce7f40cc2aa6377fda89d9ad98809d2b75 (diff)
downloadupstream-18b1cc283879c39ffe6b50d18b487448162f2139.tar.gz
upstream-18b1cc283879c39ffe6b50d18b487448162f2139.tar.bz2
upstream-18b1cc283879c39ffe6b50d18b487448162f2139.zip
px5g-wolfssl: cleanup Makefile and SPDX license
Minor cosmetic cleanups of the Makefile and add a SPDX compatible license headers. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'package/utils/px5g-wolfssl')
-rw-r--r--package/utils/px5g-wolfssl/Makefile14
-rw-r--r--package/utils/px5g-wolfssl/px5g-wolfssl.c4
2 files changed, 8 insertions, 10 deletions
diff --git a/package/utils/px5g-wolfssl/Makefile b/package/utils/px5g-wolfssl/Makefile
index a9f6a097ed..be36f9f33d 100644
--- a/package/utils/px5g-wolfssl/Makefile
+++ b/package/utils/px5g-wolfssl/Makefile
@@ -1,9 +1,6 @@
-#
# Copyright (C) 2020 Paul Spooren <mail@aparcar.org>
#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# SPDX-License-Identifier: GPL-2.0-or-later
include $(TOPDIR)/rules.mk
@@ -21,7 +18,7 @@ define Package/px5g-wolfssl
SECTION:=utils
CATEGORY:=Utilities
SUBMENU:=Encryption
- TITLE:=X.509 certificate generator (using wolfssl)
+ TITLE:=X.509 certificate generator (using WolfSSL)
DEPENDS:=+libwolfssl
PROVIDES:=px5g
VARIANT:=wolfssl
@@ -33,17 +30,14 @@ define Package/px5g-wolfssl/description
and PEM format for use with stunnel, uhttpd and others.
endef
-define Build/Prepare
- mkdir -p $(PKG_BUILD_DIR)
-endef
-
TARGET_LDFLAGS += -lwolfssl
TARGET_CFLAGS += -Wl,--gc-sections
define Build/Compile
- $(TARGET_CC) $(TARGET_CPPFLAGS) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/px5g px5g-wolfssl.c $(TARGET_LDFLAGS)
+ $(TARGET_CC) $(TARGET_CPPFLAGS) $(TARGET_CFLAGS) \
+ -o $(PKG_BUILD_DIR)/px5g px5g-wolfssl.c $(TARGET_LDFLAGS)
endef
define Package/px5g-wolfssl/install
diff --git a/package/utils/px5g-wolfssl/px5g-wolfssl.c b/package/utils/px5g-wolfssl/px5g-wolfssl.c
index 54ae9bb3ec..b937d220ca 100644
--- a/package/utils/px5g-wolfssl/px5g-wolfssl.c
+++ b/package/utils/px5g-wolfssl/px5g-wolfssl.c
@@ -1,3 +1,7 @@
+// Copyright 2020 Paul Spooren <mail@aparcar.org>
+//
+// SPDX-License-Identifier: GPL-2.0-or-later
+
#define _GNU_SOURCE
#include <stdbool.h>
#include <stdint.h>