aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/px5g-standalone/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-03-21 15:55:23 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-03-21 15:55:23 +0000
commiteb225996ee9591eaa4ad74cd6040038bd35b92cb (patch)
tree7bb18c307fb3dae7960224b7408ef04be717cbc5 /package/utils/px5g-standalone/Makefile
parent6d270ebc2b25b576a2dfdcaaa406b116f6353ea9 (diff)
downloadupstream-eb225996ee9591eaa4ad74cd6040038bd35b92cb.tar.gz
upstream-eb225996ee9591eaa4ad74cd6040038bd35b92cb.tar.bz2
upstream-eb225996ee9591eaa4ad74cd6040038bd35b92cb.zip
px5g: rename the old package to px5g-standalone, add a new one that links against polarssl
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 40000
Diffstat (limited to 'package/utils/px5g-standalone/Makefile')
-rw-r--r--package/utils/px5g-standalone/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/package/utils/px5g-standalone/Makefile b/package/utils/px5g-standalone/Makefile
new file mode 100644
index 0000000000..25777967bc
--- /dev/null
+++ b/package/utils/px5g-standalone/Makefile
@@ -0,0 +1,40 @@
+#
+# Copyright (C) 2010 Jo-Philipp Wich <xm@subsignal.org>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=px5g
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/px5g-standalone
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=Standalone X.509 certificate generator (standalone version)
+ MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
+endef
+
+define Package/px5g-standalone/description
+ Px5g is a tiny standalone X.509 certificate generator.
+ It suitable to create key files and certificates in DER
+ and PEM format for use with stunnel, uhttpd and others.
+endef
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Package/px5g-standalone/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/px5g $(1)/usr/sbin/px5g
+endef
+
+$(eval $(call BuildPackage,px5g-standalone))