aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/oseama/Makefile
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2016-01-28 22:38:23 +0000
committerRafał Miłecki <zajec5@gmail.com>2016-01-28 22:38:23 +0000
commit92443f7041bddae0a6af54f924370a16f0472e7c (patch)
tree0b8cc54823e16408f80a12235df1c48e8cfb9d81 /package/utils/oseama/Makefile
parent29112129627b19f5771953c1a5996c610c3375b1 (diff)
downloadupstream-92443f7041bddae0a6af54f924370a16f0472e7c.tar.gz
upstream-92443f7041bddae0a6af54f924370a16f0472e7c.tar.bz2
upstream-92443f7041bddae0a6af54f924370a16f0472e7c.zip
oseama: small util for reading Seama image format info
It's similar to otrx, we need this tool for handling sysupgrade. Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 48533
Diffstat (limited to 'package/utils/oseama/Makefile')
-rw-r--r--package/utils/oseama/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/package/utils/oseama/Makefile b/package/utils/oseama/Makefile
new file mode 100644
index 0000000000..ad1395c7be
--- /dev/null
+++ b/package/utils/oseama/Makefile
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2016 Rafał Miłecki <zajec5@gmail.com>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=oseama
+PKG_RELEASE:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/oseama
+ SECTION:=utils
+ CATEGORY:=Base system
+ TITLE:=Utility for handling Seama firmware images
+ MAINTAINER:=Rafał Miłecki <zajec5@gmail.com>
+ DEPENDS:=@TARGET_bcm53xx
+endef
+
+define Package/oseama/description
+ This package contains an utility that allows handling Seama images.
+endef
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ CC="$(TARGET_CC)" \
+ CFLAGS="$(TARGET_CFLAGS) -Wall"
+endef
+
+define Package/oseama/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/oseama $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,oseama))