aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/lua
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2019-08-28 20:47:02 +0200
committerDavid Bauer <mail@david-bauer.net>2019-08-31 10:31:00 +0200
commit9b0ce1789bb6d29e0fa58283bbd3ebecdf45a433 (patch)
tree7bfa820f31451146d0eaa3d7c58918513eda54f9 /package/utils/lua
parent1c0290c5cc6258c48b8ba46b4f9c85a21de4f875 (diff)
downloadupstream-9b0ce1789bb6d29e0fa58283bbd3ebecdf45a433.tar.gz
upstream-9b0ce1789bb6d29e0fa58283bbd3ebecdf45a433.tar.bz2
upstream-9b0ce1789bb6d29e0fa58283bbd3ebecdf45a433.zip
lua: create lua symlink for host installation
Since the binaries for both lua as well as lua5.3 contain the version number, invocations of the "lua" binary are failing, as it's not created anymore for the host package. Fixes: fe59b46 ("lua: include version number in installed files") Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'package/utils/lua')
-rw-r--r--package/utils/lua/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/utils/lua/Makefile b/package/utils/lua/Makefile
index a2870448bd..e376e8c472 100644
--- a/package/utils/lua/Makefile
+++ b/package/utils/lua/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=lua
PKG_VERSION:=5.1.5
-PKG_RELEASE:=5
+PKG_RELEASE:=6
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.lua.org/ftp/ \
@@ -133,6 +133,8 @@ define Host/Install
$(MAKE) -C $(HOST_BUILD_DIR) \
INSTALL_TOP="$(STAGING_DIR_HOSTPKG)" \
install
+
+ $(LN) $(STAGING_DIR_HOSTPKG)/bin/lua5.1 $(STAGING_DIR_HOSTPKG)/bin/lua
endef
define Build/InstallDev