aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/lua
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2017-01-10 18:43:57 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2017-01-10 22:15:37 +0100
commit77beaf2ec91bba0a0202ea63877ed3b399effabf (patch)
treecf7f16585546f96a575a1e4630ddd963dcc1f623 /package/utils/lua
parent7480d3309cbe40378da48c3b6decc4ba2b1fc3d5 (diff)
downloadupstream-77beaf2ec91bba0a0202ea63877ed3b399effabf.tar.gz
upstream-77beaf2ec91bba0a0202ea63877ed3b399effabf.tar.bz2
upstream-77beaf2ec91bba0a0202ea63877ed3b399effabf.zip
package: replace $(STAGING_DIR)/host with $(STAGING_DIR_HOSTPKG)
Cleanup to prepare for changing STAGING_DIR_HOSTPKG. The actual change of STAGING_DIR_HOSTPKG (i.e., moving the host packages back into a common, not target-specific directory) will be done after the first LEDE release, but the cleanup will also be useful for projects like Gluon. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'package/utils/lua')
-rw-r--r--package/utils/lua/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/utils/lua/Makefile b/package/utils/lua/Makefile
index 29de1ccd96..89b6a87117 100644
--- a/package/utils/lua/Makefile
+++ b/package/utils/lua/Makefile
@@ -111,7 +111,7 @@ define Build/Compile
endef
define Host/Configure
- $(SED) 's,"/usr/local/","$(STAGING_DIR)/host/",' $(HOST_BUILD_DIR)/src/luaconf.h
+ $(SED) 's,"/usr/local/","$(STAGING_DIR_HOSTPKG)/",' $(HOST_BUILD_DIR)/src/luaconf.h
endef
ifeq ($(HOST_OS),Darwin)
@@ -132,7 +132,7 @@ endef
define Host/Install
$(MAKE) -C $(HOST_BUILD_DIR) \
- INSTALL_TOP="$(STAGING_DIR)/host" \
+ INSTALL_TOP="$(STAGING_DIR_HOSTPKG)" \
install
endef